summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-leechcraft/lc-azoth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-leechcraft/lc-azoth')
-rw-r--r--app-leechcraft/lc-azoth/Manifest3
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-0.6.60.ebuild104
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-0.6.65.ebuild106
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-0.6.70.ebuild106
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-9999.ebuild109
-rw-r--r--app-leechcraft/lc-azoth/metadata.xml35
6 files changed, 463 insertions, 0 deletions
diff --git a/app-leechcraft/lc-azoth/Manifest b/app-leechcraft/lc-azoth/Manifest
new file mode 100644
index 000000000000..1911f838b33a
--- /dev/null
+++ b/app-leechcraft/lc-azoth/Manifest
@@ -0,0 +1,3 @@
+DIST leechcraft-0.6.60.tar.xz 5089252 SHA256 669c2325235c3c49dfc9a30d38c1ad08c0a6abf1ebbf2c8d33eca27e976e1b6d SHA512 0bac75f96bfc43c692e8b61ba5e9b6b82d535a78bd310966c36579666feb8b87217a9d74cfe792fa32b57b9b04e158239acbf2422014735d2316cbda2d8b39ec WHIRLPOOL f3056faab0006830afbcf5f3448094e530c908d432cebec731f305f34347e514db55416a911674c28445a3cd4e542136fd053ee5e444b3cf93e086dc9e88428c
+DIST leechcraft-0.6.65.tar.xz 5067580 SHA256 b821fb8716b3ba04862bbb358a738609ead84cd9c86b569fe31c712b48c2a7fd SHA512 94e3cfa42bea572cb2feeaf4c7153c8d7e08e0597d447db5033b72222cea67370e8948d0dd0e2b89585583a88b4ee3df7b32d72dcd624d383e79b9472ceffe30 WHIRLPOOL bc589f46c89351328e25e6e32febdcba8ead639a8d1daf18df7352372d66fb8f8e7e5bbef02d49b6a00a7f5ffa15d66699b79cc73f64ea1bf8b59949fcd81b8a
+DIST leechcraft-0.6.70.tar.xz 5204940 SHA256 3e7f51da0b7eec6df11471ada409d752754f3badc388b8f0adab3f056fabcd45 SHA512 fedf0467e39bd512c937b25f5da62af2be7908831169e1d82d10af43b7c164be2658138663578d7658c3692d5269dd3df9e391744561443f49771edd063ba408 WHIRLPOOL a0aef0bdc11d4b3a3680a055671208db0528bb4744930a0fecab6d1fbf99cc87f4fd8483e98e93357a4c0dda1f3edc1a20a9a725b28ea9003c564469531a2d37
diff --git a/app-leechcraft/lc-azoth/lc-azoth-0.6.60.ebuild b/app-leechcraft/lc-azoth/lc-azoth-0.6.60.ebuild
new file mode 100644
index 000000000000..36c865c6c1e3
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-0.6.60.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +murm +latex +nativeemoticons
+ +otroid +p100q +spell shx +standardstyles +vader +woodpecker +xmpp +xtazy"
+
+COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-libs/qjson
+ dev-qt/qtwebkit:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( dev-qt/qtmultimedia:4 )
+ spell? ( app-text/hunspell )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ >=net-libs/qxmpp-0.7.6
+ media? ( >=net-libs/qxmpp-0.7.6[speex] )
+ )
+ xtazy? (
+ ~app-leechcraft/lc-xtazy-${PV}
+ dev-qt/qtdbus:4
+ )
+ crypt? ( app-crypt/qca:2[qt4(+)] )"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ crypt? ( app-crypt/qca:2[gpg] )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_METACONTACTS)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable murm AZOTH_MURM)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable vader AZOTH_VADER)
+ $(cmake-utils_use_enable woodpecker AZOTH_WOODPECKER)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/app-leechcraft/lc-azoth/lc-azoth-0.6.65.ebuild b/app-leechcraft/lc-azoth/lc-azoth-0.6.65.ebuild
new file mode 100644
index 000000000000..e3ba064ad22c
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-0.6.65.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +murm +latex +nativeemoticons
+ +otroid +p100q +spell shx +standardstyles +vader +woodpecker +xmpp +xtazy"
+
+COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-libs/qjson
+ dev-qt/qtwebkit:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( dev-qt/qtmultimedia:4 )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ >=net-libs/qxmpp-0.8.0
+ media? ( >=net-libs/qxmpp-0.8.0[speex] )
+ )
+ xtazy? (
+ ~app-leechcraft/lc-xtazy-${PV}
+ dev-qt/qtdbus:4
+ )
+ crypt? ( app-crypt/qca:2[qt4(+)] )"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ crypt? ( app-crypt/qca:2[gpg] )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ spell? (
+ app-leechcraft/lc-rosenthal
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_METACONTACTS)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable murm AZOTH_MURM)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable vader AZOTH_VADER)
+ $(cmake-utils_use_enable woodpecker AZOTH_WOODPECKER)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/app-leechcraft/lc-azoth/lc-azoth-0.6.70.ebuild b/app-leechcraft/lc-azoth/lc-azoth-0.6.70.ebuild
new file mode 100644
index 000000000000..e010d37faaae
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-0.6.70.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +murm +latex +nativeemoticons
+ +otroid +spell shx +standardstyles +vader velvetbird +woodpecker +xmpp +xtazy"
+
+COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-libs/qjson
+ dev-qt/qtwebkit:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( dev-qt/qt-mobility[multimedia] )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ >=net-libs/qxmpp-0.8.0
+ media? ( >=net-libs/qxmpp-0.8.0[speex] )
+ )
+ xtazy? (
+ ~app-leechcraft/lc-xtazy-${PV}
+ dev-qt/qtdbus:4
+ )
+ crypt? ( app-crypt/qca:2[qt4(+)] )"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ crypt? ( app-crypt/qca:2[gpg] )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ spell? (
+ app-leechcraft/lc-rosenthal
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_METACONTACTS)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable murm AZOTH_MURM)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable vader AZOTH_VADER)
+ $(cmake-utils_use_enable velvetbird AZOTH_VELVETBIRD)
+ $(cmake-utils_use_enable woodpecker AZOTH_WOODPECKER)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
new file mode 100644
index 000000000000..c03d941b839a
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +murm +latex +nativeemoticons
+ +otroid +spell sarin shx +standardstyles +vader velvetbird +woodpecker +xmpp +xtazy"
+
+COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-libs/qjson
+ dev-qt/qtwebkit:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( dev-qt/qt-mobility[multimedia] )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ =net-libs/qxmpp-9999
+ media? ( =net-libs/qxmpp-9999[speex] )
+ )
+ xtazy? (
+ ~app-leechcraft/lc-xtazy-${PV}
+ dev-qt/qtdbus:4
+ )
+ crypt? ( app-crypt/qca:2[qt4(+)] )
+ sarin? ( net-libs/tox )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ crypt? ( app-crypt/qca:2[gpg] )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ spell? (
+ app-leechcraft/lc-rosenthal
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_METACONTACTS)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable murm AZOTH_MURM)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable sarin AZOTH_SARIN)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable vader AZOTH_VADER)
+ $(cmake-utils_use_enable velvetbird AZOTH_VELVETBIRD)
+ $(cmake-utils_use_enable woodpecker AZOTH_WOODPECKER)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/app-leechcraft/lc-azoth/metadata.xml b/app-leechcraft/lc-azoth/metadata.xml
new file mode 100644
index 000000000000..5ee5f1b54811
--- /dev/null
+++ b/app-leechcraft/lc-azoth/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>leechcraft</herd>
+<use>
+ <flag name="astrality">Build Astrality, support for protocols provided by Telepathy</flag>
+ <flag name="acetamide">Build Acetamide, the IRC protocol support</flag>
+ <flag name="adiumstyles">Build support for Adium styles</flag>
+ <flag name="autoidler">Build support for automatic status changing according to user idle time</flag>
+ <flag name="autopaste">Build Autopaste for pasting long texts to pastebins</flag>
+ <flag name="birthdaynotifier">Build Birthday Notifier for you to not forget about birthdays of your contacts.</flag>
+ <flag name="chathistory">Build ChatHistory which stories chat history</flag>
+ <flag name="depester">Build Depester which enables to ignore MUC participants</flag>
+ <flag name="embedmedia">Build EmbedMedia for embedding flash videos and images directly into chat windows</flag>
+ <flag name="herbicide">Build Herbicide, a basic antispam plugin</flag>
+ <flag name="hili">Build HiLi which allows to customize highlight settings in MUCs</flag>
+ <flag name="isterique">Build Isterique plugin for neutralizing excessive caps lock usage</flag>
+ <flag name="juick">Build plugin for the Juick.com microblogging service</flag>
+ <flag name="keeso">Build plugin for changing text into SoMEtHInG lIKe THiS</flag>
+ <flag name="lastseen">Build plugin for client-side recording of the last online/available time</flag>
+ <flag name="metacontacts">Build plugin for metacontacts support</flag>
+ <flag name="media">Enable media calls</flag>
+ <flag name="murm">Build Murm, the VKontakte messaging support via their native API (instead of XMPP)</flag>
+ <flag name="nativeemoticons">Build support for native Azoth's emoticons packs</flag>
+ <flag name="otroid">Build OTRoid, plugin for the Off-the-Record deniable encryption system</flag>
+ <flag name="p100q">Build p100q, plugin for psto.net microblogging service</flag>
+ <flag name="sarin">Build Sarin, Tox protocol support module. Please add mva overlay to use <pkg>net-libs/tox</pkg></flag>
+ <flag name="shx">Build shell command executor plugin</flag>
+ <flag name="standardstyles">Build support for standard Azoth styles engine</flag>
+ <flag name="vader">Bulid Vader, the MRIM (Mail.Ru Agent) protocol support plugin</flag>
+ <flag name="velvetbird">Build support for protocols provided by libpurple</flag>
+ <flag name="woodpecker">Build Woodpecker, the Twitter client plugin</flag>
+ <flag name="xtazy">Build Xtazy for publishing currently playing tune</flag>
+</use>
+</pkgmetadata>