summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/digitemp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest1
-rw-r--r--app-misc/digitemp/digitemp-3.5.0-r2.ebuild76
-rw-r--r--app-misc/digitemp/metadata.xml23
3 files changed, 100 insertions, 0 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
new file mode 100644
index 000000000000..83c5ddf265e7
--- /dev/null
+++ b/app-misc/digitemp/Manifest
@@ -0,0 +1 @@
+DIST digitemp-3.5.0.tar.gz 267947 SHA256 e185ef9b84501b28568160eb5a5cc3b98b72c0791aff9c128ff6d0cd23b711e8 SHA512 59055a97ae35cdc86bb893a755975b688d3be9185e717f5da0024d664e6c93dd5a7f10f1230772c3bc1bc76a088392da083ba63d28e054727b9f68ce31de64d3 WHIRLPOOL d10bda164dee77a8f0c90330a2799a1f37d4c2f8b8c9709df1fa91939ccbc93f660c5184dadbb52f9d5cf80acf7fbd018e93d7f46283e5a5a6195bb257e4928f
diff --git a/app-misc/digitemp/digitemp-3.5.0-r2.ebuild b/app-misc/digitemp/digitemp-3.5.0-r2.ebuild
new file mode 100644
index 000000000000..a07c5fe338db
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.5.0-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com/ http://www.ibutton.com/"
+SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
+
+IUSE="ds9097 ds9097u ds2490"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+
+DEPEND="ds2490? ( virtual/libusb:0 )"
+
+targets() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ echo ds9097u
+ fi
+ for target in ds9097 ds9097u ds2490; do
+ if use ${target}; then
+ echo ${target}
+ fi
+ done
+}
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" Makefile
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ ewarn "If you don't choose a component to install, we default to ds9097u"
+ fi
+}
+
+src_compile() {
+ local targets=$(targets)
+
+ for target in $targets; do
+ emake clean
+ emake CC="$(tc-getCC)" LOCK="no" ${target} || die "emake ${target} failed"
+ done
+}
+
+src_install() {
+ for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
+ dobin digitemp_${target} && \
+ dosym digitemp_${target} /usr/bin/digitemp
+ done
+
+ if [[ $(targets|wc -l) -ge 1 ]]; then
+ echo
+ ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
+ ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
+ echo
+ fi
+
+ dodoc README FAQ TODO
+
+ for example in perl python rrdb; do
+ insinto "/usr/share/doc/${PF}/${example}_examples"
+ doins -r ${example}/*
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "Examples of using digitemp with python, perl, and rrdtool are"
+ elog "located in /usr/share/doc/${PF}/"
+ echo
+}
diff --git a/app-misc/digitemp/metadata.xml b/app-misc/digitemp/metadata.xml
new file mode 100644
index 000000000000..a1eaad9f69af
--- /dev/null
+++ b/app-misc/digitemp/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+DigiTemp is a simple to use program for reading values from 1-wire devices. Its
+main use is for reading temperature sensors, but it also reads counters, and
+understands the 1-wire hubs with devices on different branches of the network.
+DigiTemp now supports the following 1-wire temperature sensors: DS18S20 (and
+DS1820), DS18B20, DS1822, the DS2438 Smart Battery Monitor, DS2422 and DS2423
+Counters, DS2409 MicroLAN Coupler (used in 1-wire hubs), and the AAG TAI-8540
+humidity sensor.
+</longdescription>
+<use>
+ <flag name='ds2490'>Build support for the ds2490 sensor</flag>
+ <flag name='ds9097'>Build support for the ds9097 sensor</flag>
+ <flag name='ds9097u'>Build support for the ds9097u sensor</flag>
+</use>
+</pkgmetadata>