summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-09-06 15:53:37 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-09-06 16:01:37 -0400
commit39b81ac611f10dc2a7adeafcec64720aba99f3e3 (patch)
tree49ed8def7ea4728c186adcf1b4409a623f6c7ae3 /app-misc/trash-cli
parentpackage.mask: unmask aiohttp-3 (diff)
downloadgentoo-39b81ac611f10dc2a7adeafcec64720aba99f3e3.tar.gz
gentoo-39b81ac611f10dc2a7adeafcec64720aba99f3e3.tar.bz2
gentoo-39b81ac611f10dc2a7adeafcec64720aba99f3e3.zip
app-misc/trash-cli: bump to 0.17.1.14_p20170816
Patch by Alex Xu Closes: https://bugs.gentoo.org/643488 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-misc/trash-cli')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 65fc7ac980ad..e562fe9e26b4 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,3 +1,4 @@
DIST trash-cli-0.12.9.14.tar.gz 62090 BLAKE2B b227fe852aa204156b197e14e8dd34e1f9883f0dde11512842a2705ea20d781db031552f4b355096521fe720cd48d6fded74aa5d173d423bd3b6b8e77f413a1a SHA512 3846ec4e2e491b09ad93134313a875fb3e072abe3e895956b62a3e4f350c1f10dd1ded3fea0caec3fa8a6bd39f2d0a63ac6a3a070a6204fd2f27f1e447f5ba6c
DIST trash-cli-0.16.12.29.tar.gz 66826 BLAKE2B 0d8b56a1ac23272ea9c53b732e679ce4b92173e404afeb7611d781cebde32ff9895d751176ab038444fd5a98920ab725cca909c5920d9c28ab32408bf5fe2e84 SHA512 a8a94205233ac600a98324b95829d1f00debaca95c85c51fa12f7a65ae6f24fda58370d8fe0095bf33327cbddae7dfb02c2587efffd2d7c206c7f7cb0a59953e
DIST trash-cli-0.17.1.14.tar.gz 69141 BLAKE2B 028274ea2753eb3ff4bfec5929dafcf090d05938154eb20ce02559e696310a647643275a64c2278c9dd8e71442c5e32dc77a87f095c14c2bbe5f98931e627604 SHA512 29033d6e780d81ca762cb69d571c1fa8608f7e84564600d1f7a92141acecf9d7c770e7ff6dcac8f98701af4c6aec3874634eba0af0e92fc2b98ce99c5550c14d
+DIST trash-cli-0.17.1.14_p20170816.tar.gz 69713 BLAKE2B f995c22ba0704eba96abac2c130f9118cc98ad5c5f21903601ea60ee1f52c594b7f8b16ebcaabb4b34086f5f9f66ad02cd628c379ed5139bcb1f691016b435ab SHA512 9d35620b55c63b53b7255179a6304f4d7190c2a90f68c102f64b9616ee897460939633e9c77826968a1682fc5fa090b0f3ea1daad82a44cc96704dc54da45dcd
diff --git a/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild b/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild
new file mode 100644
index 000000000000..769a796bf485
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit distutils-r1 vcs-snapshot
+
+GIT_REF=5abecd53e1d84f2a5fd3fc60d2f5d71e518826c5
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${GIT_REF}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v || die
+}