summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-25 13:03:22 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-25 13:08:04 +0100
commit0dfa9a21a1586d6b3df25f86f9f5ab8d0c229945 (patch)
treee7d7cb28aef8115feeb8f661f5d9c82a7938e4d1 /app-misc
parentnet-analyzer/wireshark: Update sse4_2 patch. (diff)
downloadgentoo-0dfa9a21a1586d6b3df25f86f9f5ab8d0c229945.tar.gz
gentoo-0dfa9a21a1586d6b3df25f86f9f5ab8d0c229945.tar.bz2
gentoo-0dfa9a21a1586d6b3df25f86f9f5ab8d0c229945.zip
app-misc/birthday: Fix test failures
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568930 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/birthday/birthday-1.6.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-misc/birthday/birthday-1.6.2.ebuild b/app-misc/birthday/birthday-1.6.2.ebuild
index 600b93523b1b..c8f79f8f04da 100644
--- a/app-misc/birthday/birthday-1.6.2.ebuild
+++ b/app-misc/birthday/birthday-1.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,8 +18,12 @@ src_unpack() {
cd "${S}"
# Don't strip, install in correct share dir and respect CFLAGS
- sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
- Makefile || die
+ sed \
+ -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ -i Makefile || die
+ sed \
+ -e 's:grep -v:grep --binary-files=text -v:g' \
+ -i runtest.sh || die
}
src_compile() {