summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-01-27 14:26:11 +0100
committerWolfram Schlich <wschlich@gentoo.org>2016-01-27 14:26:11 +0100
commit57843db712e10b6d08cd22631b15b04097850c74 (patch)
tree947a8d74f016f6a36ff317e95bfc1ec505ad4ceb /app-misc
parentdev-libs/cyberjack: version bump (diff)
downloadgentoo-57843db712e10b6d08cd22631b15b04097850c74.tar.gz
gentoo-57843db712e10b6d08cd22631b15b04097850c74.tar.bz2
gentoo-57843db712e10b6d08cd22631b15b04097850c74.zip
app-misc/digitemp: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/digitemp/Manifest1
-rw-r--r--app-misc/digitemp/digitemp-3.7.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 83c5ddf265e7..8edef76bea44 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1 +1,2 @@
DIST digitemp-3.5.0.tar.gz 267947 SHA256 e185ef9b84501b28568160eb5a5cc3b98b72c0791aff9c128ff6d0cd23b711e8 SHA512 59055a97ae35cdc86bb893a755975b688d3be9185e717f5da0024d664e6c93dd5a7f10f1230772c3bc1bc76a088392da083ba63d28e054727b9f68ce31de64d3 WHIRLPOOL d10bda164dee77a8f0c90330a2799a1f37d4c2f8b8c9709df1fa91939ccbc93f660c5184dadbb52f9d5cf80acf7fbd018e93d7f46283e5a5a6195bb257e4928f
+DIST digitemp-3.7.1.tar.gz 144870 SHA256 6fa4d965350d5501b6ca73ee8a09276ca4f65b6d85dae62f0a796239bae5000e SHA512 e5eaf576b544c61049a358dece7dc96d9793b751ef08645060f3b2c1a2006e2906c3aa3f97de3dab46818290d664d2e784a948b2495b538a200b6d71b03173d2 WHIRLPOOL 0448de6833a1b182ba1fc78f7aaa4fb1fde5dd6b10d027a66008aee3893e09c3ed82bc09ae4ab5efedf875cab0a537a0b78c277d43f93e4766d8d895678c38d5
diff --git a/app-misc/digitemp/digitemp-3.7.1.ebuild b/app-misc/digitemp/digitemp-3.7.1.ebuild
new file mode 100644
index 000000000000..80024ae592c2
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.7.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com/ http://www.ibutton.com/"
+SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="ds9097 ds9097u ds2490"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="ds2490? ( virtual/libusb:0 )"
+
+targets() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ echo ds9097u
+ fi
+ for target in ds9097 ds9097u ds2490; do
+ if use ${target}; then
+ echo ${target}
+ fi
+ done
+}
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" Makefile
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ ewarn "If you don't choose a component to install, we default to ds9097u"
+ fi
+}
+
+src_compile() {
+ local targets=$(targets)
+
+ for target in $targets; do
+ emake clean
+ emake CC="$(tc-getCC)" LOCK="no" ${target} || die "emake ${target} failed"
+ done
+}
+
+src_install() {
+ for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
+ dobin digitemp_${target} && \
+ dosym digitemp_${target} /usr/bin/digitemp
+ done
+
+ if [[ $(targets|wc -l) -ge 1 ]]; then
+ echo
+ ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
+ ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
+ echo
+ fi
+
+ dodoc README FAQ TODO
+
+ for example in perl python rrdb; do
+ insinto "/usr/share/doc/${PF}/${example}_examples"
+ doins -r ${example}/*
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "Examples of using digitemp with python, perl, and rrdtool are"
+ elog "located in /usr/share/doc/${PF}/"
+ echo
+}