summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-09-30 15:32:47 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-09-30 15:32:47 +0300
commitcd92e1378c7695128b02c2686cf3ff037b772f38 (patch)
tree695ed6e72809abe583f291b0945beb228fc24412 /app-misc
parentdev-libs/hsa-ext-rocr: remove old (diff)
downloadgentoo-cd92e1378c7695128b02c2686cf3ff037b772f38.tar.gz
gentoo-cd92e1378c7695128b02c2686cf3ff037b772f38.tar.bz2
gentoo-cd92e1378c7695128b02c2686cf3ff037b772f38.zip
app-misc/pip3line: remove last-rited package
Closes: https://bugs.gentoo.org/693184 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pip3line/Manifest1
-rw-r--r--app-misc/pip3line/metadata.xml10
-rw-r--r--app-misc/pip3line/pip3line-3.6.0.ebuild88
-rw-r--r--app-misc/pip3line/pip3line-9999.ebuild88
4 files changed, 0 insertions, 187 deletions
diff --git a/app-misc/pip3line/Manifest b/app-misc/pip3line/Manifest
deleted file mode 100644
index 25f8349bf5a1..000000000000
--- a/app-misc/pip3line/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pip3line-3.6.0.tar.gz 736294 BLAKE2B 75bc3bcd3ad547a31a1fc97f525a8575136ba1bcb48e5e9d7292732c04d2a62cd03710a4e6d76a652d5259e5081cf8cc8c2dfc3265ecf1f3ea5cbc6870c02ab6 SHA512 4263d18749533f1137dc3546a6a5b5856f9c5dc09355c866c7e6a8fc59787c84ee979f648f563c465aab314ff9155bba6e34e7d4641438d96bdb786c93dfaec8
diff --git a/app-misc/pip3line/metadata.xml b/app-misc/pip3line/metadata.xml
deleted file mode 100644
index a89190752a47..000000000000
--- a/app-misc/pip3line/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <use>
- <flag name='distorm'>Compile the Distorm plugin</flag>
- <flag name='qscintilla'>Use QScintilla for more efficient text display</flag>
- <flag name='ssl'>Compile the plugin adding miscellaneous hashes from OpenSSL</flag>
- </use>
-</pkgmetadata>
diff --git a/app-misc/pip3line/pip3line-3.6.0.ebuild b/app-misc/pip3line/pip3line-3.6.0.ebuild
deleted file mode 100644
index 6bc81c630244..000000000000
--- a/app-misc/pip3line/pip3line-3.6.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-utils python-r1 python-utils-r1
-
-DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
-HOMEPAGE="https://github.com/metrodango/pip3line"
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# A few comments
-# the ssl flag is just there to enable the plugin for low level crypto algorithms.
-# It has nothing to do with the SSL/TLS protocol itself.
-
-IUSE="distorm python qscintilla ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxmlpatterns:5
- qscintilla? ( x11-libs/qscintilla )
- ssl? ( dev-libs/openssl:0= )"
-
-DEPEND="${RDEPEND}
- distorm? ( dev-vcs/git )"
-
-src_configure() {
-
- local mycmakeargs=(
- -DBASIC=yes
- -DWITH_DISTORM=$(usex distorm)
- -DWITH_OPENSSL=$(usex ssl)
- -DWITH_SCINTILLA=$(usex qscintilla)
- )
-
- # distorm is statically linked, due to insufficiencies
- # in the current distorm64 package
-
- if use distorm; then
- mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
- fi
-
- if use python; then
- local targets=( ${PYTHON_TARGETS} )
- for target in ${targets[@]}; do
- if python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON3=ON
- -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- for target in ${targets[@]}; do
- if ! python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON27=ON
- -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- fi
-
- cmake-utils_src_configure
-}
diff --git a/app-misc/pip3line/pip3line-9999.ebuild b/app-misc/pip3line/pip3line-9999.ebuild
deleted file mode 100644
index 6bc81c630244..000000000000
--- a/app-misc/pip3line/pip3line-9999.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-utils python-r1 python-utils-r1
-
-DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
-HOMEPAGE="https://github.com/metrodango/pip3line"
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# A few comments
-# the ssl flag is just there to enable the plugin for low level crypto algorithms.
-# It has nothing to do with the SSL/TLS protocol itself.
-
-IUSE="distorm python qscintilla ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxmlpatterns:5
- qscintilla? ( x11-libs/qscintilla )
- ssl? ( dev-libs/openssl:0= )"
-
-DEPEND="${RDEPEND}
- distorm? ( dev-vcs/git )"
-
-src_configure() {
-
- local mycmakeargs=(
- -DBASIC=yes
- -DWITH_DISTORM=$(usex distorm)
- -DWITH_OPENSSL=$(usex ssl)
- -DWITH_SCINTILLA=$(usex qscintilla)
- )
-
- # distorm is statically linked, due to insufficiencies
- # in the current distorm64 package
-
- if use distorm; then
- mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
- fi
-
- if use python; then
- local targets=( ${PYTHON_TARGETS} )
- for target in ${targets[@]}; do
- if python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON3=ON
- -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- for target in ${targets[@]}; do
- if ! python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON27=ON
- -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- fi
-
- cmake-utils_src_configure
-}