summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-03 21:48:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-03 22:54:05 +0200
commitd6a49de56b25c8e4980690704a1df9cee20675ca (patch)
tree43fe373c1995e3e3989115bc69d417743a476ee2 /app-misc
parentapp-misc/sl: honor CC. (diff)
downloadgentoo-d6a49de56b25c8e4980690704a1df9cee20675ca.tar.gz
gentoo-d6a49de56b25c8e4980690704a1df9cee20675ca.tar.bz2
gentoo-d6a49de56b25c8e4980690704a1df9cee20675ca.zip
app-misc/i2bits: honor CFLAGS.
Closes: https://bugs.gentoo.org/722396 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/i2bits/i2bits-0.1.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-misc/i2bits/i2bits-0.1.0.ebuild b/app-misc/i2bits/i2bits-0.1.0.ebuild
index 4bb902c770b3..e877529fb905 100644
--- a/app-misc/i2bits/i2bits-0.1.0.ebuild
+++ b/app-misc/i2bits/i2bits-0.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Utility to convert hex or dec to binary format"
HOMEPAGE="https://bitbucket.org/PascalRD/i2bits/"
@@ -12,3 +12,11 @@ SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
LICENSE="WTFPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
+
+src_prepare() {
+ sed -e "s/^set(CMAKE_C_FLAGS.*/set(CMAKE_C_FLAGS \"${CFLAGS}\")/" \
+ -e "1s/^/project(${PN})\n/" \
+ -i CMakeLists.txt || die "can't patch CMakeLists.txt"
+
+ cmake-utils_src_prepare
+}