summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Caudrelier <gabriel.caudrelier@gmail.com>2018-10-29 21:33:54 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-29 15:48:34 -0500
commite0ecbeb23685caa949b18000e6e4f188cc710375 (patch)
tree42e83c1e0f4eed363736606459b26dfcb774cdcd /app-misc
parentdev-util/stressapptest: Remove old (diff)
downloadgentoo-e0ecbeb23685caa949b18000e6e4f188cc710375.tar.gz
gentoo-e0ecbeb23685caa949b18000e6e4f188cc710375.tar.bz2
gentoo-e0ecbeb23685caa949b18000e6e4f188cc710375.zip
app-misc/pip3line: Add new package
Signed-off-by: Gabriel Caudrelier <gabriel.caudrelier@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Bug: https://bugs.gentoo.org/667984 Closes: https://github.com/gentoo/gentoo/pull/10336 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pip3line/Manifest1
-rw-r--r--app-misc/pip3line/metadata.xml17
-rw-r--r--app-misc/pip3line/pip3line-3.5.4.ebuild87
-rw-r--r--app-misc/pip3line/pip3line-9999.ebuild87
4 files changed, 192 insertions, 0 deletions
diff --git a/app-misc/pip3line/Manifest b/app-misc/pip3line/Manifest
new file mode 100644
index 000000000000..49dcda22a145
--- /dev/null
+++ b/app-misc/pip3line/Manifest
@@ -0,0 +1 @@
+DIST pip3line-3.5.4.tar.gz 732872 BLAKE2B e544a2e1af958f3b1ef2e523d8489c807976523109ef8cc73f2c43b543ba9bd0b48d49009637d386e69f7768db6e2bd5a8f098d30dbd199a0b3d6bdaf782c103 SHA512 4a5421e4bf197d8ba2802c3007cfdd4d75a8c356f5bd8774d7f50bb3301e6beb52cc06f7d3486e85c3eaa16d192643afeb00b95e4d174ce16665b509e522ee6a
diff --git a/app-misc/pip3line/metadata.xml b/app-misc/pip3line/metadata.xml
new file mode 100644
index 000000000000..9cc54c99226b
--- /dev/null
+++ b/app-misc/pip3line/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gabriel.caudrelier@gmail.com</email>
+ <name>Gabriel Caudrelier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name='distorm'>Compile the Distorm plugin</flag>
+ <flag name='qscintilla'>Use QScintilla for more efficient text display</flag>
+ <flag name='ssl'>Compile the plugin adding miscellaneous hashes from OpenSSL</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-misc/pip3line/pip3line-3.5.4.ebuild b/app-misc/pip3line/pip3line-3.5.4.ebuild
new file mode 100644
index 000000000000..9789c01998c4
--- /dev/null
+++ b/app-misc/pip3line/pip3line-3.5.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
+HOMEPAGE="https://github.com/metrodango/pip3line"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# A few comments
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# It has nothing to do with the SSL/TLS protocol itself.
+
+IUSE="distorm python qscintilla ssl"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxmlpatterns:5
+ qscintilla? ( x11-libs/qscintilla )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ distorm? ( dev-vcs/git )"
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DBASIC=yes
+ -DWITH_DISTORM=$(usex distorm)
+ -DWITH_OPENSSL=$(usex ssl)
+ -DWITH_SCINTILLA=$(usex qscintilla)
+ )
+
+ # distorm is statically linked, due to insufficiencies
+ # in the current distorm64 package
+
+ if use distorm; then
+ mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
+ fi
+
+ if use python; then
+ local targets=( ${PYTHON_TARGETS} )
+ for target in ${targets[@]}; do
+ if python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ for target in ${targets[@]}; do
+ if ! python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON27=ON
+ -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/app-misc/pip3line/pip3line-9999.ebuild b/app-misc/pip3line/pip3line-9999.ebuild
new file mode 100644
index 000000000000..9789c01998c4
--- /dev/null
+++ b/app-misc/pip3line/pip3line-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
+HOMEPAGE="https://github.com/metrodango/pip3line"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# A few comments
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# It has nothing to do with the SSL/TLS protocol itself.
+
+IUSE="distorm python qscintilla ssl"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxmlpatterns:5
+ qscintilla? ( x11-libs/qscintilla )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ distorm? ( dev-vcs/git )"
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DBASIC=yes
+ -DWITH_DISTORM=$(usex distorm)
+ -DWITH_OPENSSL=$(usex ssl)
+ -DWITH_SCINTILLA=$(usex qscintilla)
+ )
+
+ # distorm is statically linked, due to insufficiencies
+ # in the current distorm64 package
+
+ if use distorm; then
+ mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
+ fi
+
+ if use python; then
+ local targets=( ${PYTHON_TARGETS} )
+ for target in ${targets[@]}; do
+ if python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ for target in ${targets[@]}; do
+ if ! python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON27=ON
+ -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ fi
+
+ cmake-utils_src_configure
+}