summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-01 13:45:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-01 13:45:49 +0200
commitf4ce9f594688a949efc254b9d3ec13c64bcaa629 (patch)
tree0878ddad258213f202769797d4cc3ffda15b7f48 /app-misc
parentmail-client/alpine: amd64 stable wrt bug #654284 (diff)
downloadgentoo-f4ce9f594688a949efc254b9d3ec13c64bcaa629.tar.gz
gentoo-f4ce9f594688a949efc254b9d3ec13c64bcaa629.tar.bz2
gentoo-f4ce9f594688a949efc254b9d3ec13c64bcaa629.zip
app-misc/hivex: Remove 1.3.11-r1 due to broken dep syntax
Remove the old version since it uses empty dep groups which causes repoman errors: dependency.syntax [fatal] 4 app-misc/hivex/hivex-1.3.11-r1.ebuild: DEPEND: expected: dependency string, got: ')', token 18 app-misc/hivex/hivex-1.3.11-r1.ebuild: RDEPEND: expected: dependency string, got: ')', token 18 app-misc/hivex/hivex-1.3.11-r1.ebuild: DEPEND: expected: dependency string, got: ')', token 18 app-misc/hivex/hivex-1.3.11-r1.ebuild: RDEPEND: expected: dependency string, got: ')', token 18 and causes pkgcheck to crash, causing major mayhem everywhere.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hivex/Manifest1
-rw-r--r--app-misc/hivex/hivex-1.3.11-r1.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/app-misc/hivex/Manifest b/app-misc/hivex/Manifest
index 7d62b6cdcd66..a3290cd9d4d8 100644
--- a/app-misc/hivex/Manifest
+++ b/app-misc/hivex/Manifest
@@ -1,2 +1 @@
-DIST hivex-1.3.11.tar.gz 1264487 BLAKE2B ba2f72d174ed1b807ef97bc3a5cdec10219b01c1719a0a9dd262ce4a8474a808c73d2f14e9d3347ed44485b08b77bb3638212a24159b5aa153189848e755e5e4 SHA512 1ff9fbcfb976fea5bba41c5ff06e4dc68af0e507accc236ca0406644ee2c865619b3b3bf9550124778fcd782ddc257f1d89861b45f48c0c3ceed18dfa1e02ced
DIST hivex-1.3.14.tar.gz 1332257 BLAKE2B fe7c19e05d29c7e98a334842cc1144aa76b148a3b7aae91449a4923a124eb54227a9a004346ef3558732c688c4f92cacd0c9328056930c33dba0404465634da0 SHA512 dd7dd52dceda580179a815fc48a2a2c7e8f7234614beceb937fba7e317df17984e65453338160c4c467b70d7d4f9bd61b48aad3ca51e19bd5e4cfbca8ee3adb6
diff --git a/app-misc/hivex/hivex-1.3.11-r1.ebuild b/app-misc/hivex/hivex-1.3.11-r1.ebuild
deleted file mode 100644
index 89044477d977..000000000000
--- a/app-misc/hivex/hivex-1.3.11-r1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-USE_RUBY="ruby21 ruby22"
-RUBY_OPTIONAL=yes
-
-PYTHON_COMPAT=(python2_7 python3_{4,5,6})
-
-inherit autotools-utils eutils perl-app ruby-ng python-single-r1
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="ocaml readline +perl python test static-libs ruby"
-
-RDEPEND="
- virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline:0 )
- perl? ( dev-perl/IO-stringy )
- ruby? ( $(ruby_implementations_depend) )
- python? ( ${PYTHON_DEPS} )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- "
-
-ruby_add_bdepend "ruby? ( dev-ruby/rake
- virtual/rubygems
- dev-ruby/rdoc )"
-ruby_add_rdepend "ruby? ( virtual/rubygems )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DOCS=( README )
-S="${WORKDIR}/${P}"
-
-#We are aware of rather poor quality of this ebuild, but the bump is required to fix security bug. We will fix other matters later.
-
-pkg_setup() {
- if use python; then
- python-single-r1_pkg_setup
- fi
- if use perl; then
- perl_set_version
- fi
-}
-
-src_unpack() {
- default
-}
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-
- if use perl; then
- pushd perl
- perl-app_src_configure
- popd
- fi
-}
-
-src_compile() {
- autotools-utils_src_compile
-}
-
-# Test binding's dont't wok properly in gentoo layout
-#src_test() {
-# if use perl;then
-# pushd perl
-# perl-app_src_install
-# popd
-# fi
-#
-# autotools-utils_src_compile check
-#}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- perl_delete_localpod
- fi
-}