summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-11-28 20:41:42 +0100
committerPacho Ramos <pacho@gentoo.org>2017-11-28 20:46:20 +0100
commitd3e32d54d4408da857911c2b0e14ac2c86d31a18 (patch)
tree9e9d827ae9c86858ce4296644efe60e09a926637 /app-mobilephone
parentnet-dialup/mgetty: Fix building with gcc7 (#639076 by Toralf Förster) (diff)
downloadgentoo-d3e32d54d4408da857911c2b0e14ac2c86d31a18.tar.gz
gentoo-d3e32d54d4408da857911c2b0e14ac2c86d31a18.tar.bz2
gentoo-d3e32d54d4408da857911c2b0e14ac2c86d31a18.zip
app-mobilephone/gnokii: Fix building with gcc7 (#639078 by Toralf Förster)
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gnokii/Manifest2
-rw-r--r--app-mobilephone/gnokii/files/gnokii-0.6.31-gcc7.patch17
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.31-r1.ebuild8
3 files changed, 23 insertions, 4 deletions
diff --git a/app-mobilephone/gnokii/Manifest b/app-mobilephone/gnokii/Manifest
index 89bde8292941..d8f2ef26b3e5 100644
--- a/app-mobilephone/gnokii/Manifest
+++ b/app-mobilephone/gnokii/Manifest
@@ -1 +1 @@
-DIST gnokii-0.6.31.tar.bz2 1237865 SHA256 8f5a083b05c1a66a3402ca5cd80084e14c2c0632c991bb53b03c78e9adb02501 SHA512 529f6d0d29873f48ac00cf7151ba35dcbd93405ab27d69848ed17dea73f4fba71721d1811d921441b4214777b9b33f760b372631627cc108eb94c39684da343d WHIRLPOOL a14927d205748647187336f408fc7449808e48ff2b6de0df8cc14562d25a67643d1bb4cb97f50c27a5c2acad2bdb503bcec049a4fdac534ce48c763b9715cae7
+DIST gnokii-0.6.31.tar.bz2 1237865 BLAKE2B d94c5d44e7075b875037c55448b63c76a27116ad09eeb3c450597d6d65d0cabae65aefc904dcdd868b30fbd17989ce50aecfb2d08dce8ac55e36d1976f0b61da SHA512 529f6d0d29873f48ac00cf7151ba35dcbd93405ab27d69848ed17dea73f4fba71721d1811d921441b4214777b9b33f760b372631627cc108eb94c39684da343d
diff --git a/app-mobilephone/gnokii/files/gnokii-0.6.31-gcc7.patch b/app-mobilephone/gnokii/files/gnokii-0.6.31-gcc7.patch
new file mode 100644
index 000000000000..6637a6af62c4
--- /dev/null
+++ b/app-mobilephone/gnokii/files/gnokii-0.6.31-gcc7.patch
@@ -0,0 +1,17 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for gnokii <= 0.6.31 to avoid
+build failures with GCC 7.x as "../common/.libs/libgnokii.so: undefined reference
+to `local_atoi'". The "inline" is only a hint that the compiler doesn't complain
+about double defined symbols, but does not guarantee that a function is inlined
+or that a symbol is generated when needed.
+
+--- gnokii-0.6.31/common/gsm-filetypes.c 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/common/gsm-filetypes.c.gcc7 2017-02-12 00:55:39.000000000 +0100
+@@ -1409,7 +1409,7 @@
+ #define GET_NEXT_TOKEN() o = get_next_token(line + offset, ';')
+ #define STORE_TOKEN(a) strip_slashes(a, line + offset, sizeof(a) - 1, o - 1)
+
+-inline int local_atoi(char *str, int len)
++static int local_atoi(char *str, int len)
+ {
+ int retval;
+ char *aux = strndup(str, len);
diff --git a/app-mobilephone/gnokii/gnokii-0.6.31-r1.ebuild b/app-mobilephone/gnokii/gnokii-0.6.31-r1.ebuild
index 17779551f5d6..d85decce8d49 100644
--- a/app-mobilephone/gnokii/gnokii-0.6.31-r1.ebuild
+++ b/app-mobilephone/gnokii/gnokii-0.6.31-r1.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
inherit autotools eutils linux-info
HOMEPAGE="http://www.gnokii.org/"
@@ -32,11 +31,13 @@ RDEPEND="
mysql? ( virtual/mysql:= )
)
usb? ( virtual/libusb:0 )
- X? ( x11-libs/gtk+:2 )"
+ X? ( x11-libs/gtk+:2 )
+"
DEPEND="${RDEPEND}
dev-util/intltool
irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
CONFIG_CHECK="~UNIX98_PTYS"
@@ -50,6 +51,7 @@ IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
PATCHES=(
"${FILESDIR}"/${P}-fix_xgnokii_inclusion.patch
"${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-gcc7.patch
)
src_prepare() {