summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-08-31 20:13:05 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-08-31 20:19:41 +0200
commit235757380f5d938363bbeb90c5e9b52cbf766803 (patch)
tree4d064836df9379d7c8281b9a8259d366b5601512 /app-office/gnumeric
parentx11-libs/goffice: drop old revision (diff)
downloadgentoo-235757380f5d938363bbeb90c5e9b52cbf766803.tar.gz
gentoo-235757380f5d938363bbeb90c5e9b52cbf766803.tar.bz2
gentoo-235757380f5d938363bbeb90c5e9b52cbf766803.zip
app-office/gnumeric: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.23.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 6192cb8e40bb..3d1fb99f6519 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,2 +1,3 @@
DIST gnumeric-1.12.21.tar.xz 18460624 SHA256 6eed42120babb7b2a857115f2ad6320bf255c7bd71a939344e5a6df744a09ef4 SHA512 5341cf04fe0f1115e8bda53fce57650b44195d482abef5f9f8c5683de756007df5f167d5df0ae2ea5a40d06b7cce3ab67233d49cbe28a32eadbd1dced16c773d WHIRLPOOL 3339aab18bd2bcf4c32417d7b92093c9deac730553fc79046e6138ed4c6234d2830c8c3392493b7e314c4c87983f36b9c385f69c020538426c4f2788900c9338
DIST gnumeric-1.12.22.tar.xz 18541384 SHA256 3908cfd6520b599eefefe222aadeaa5126394b54d9a9a7f5e0f938eb674dcf47 SHA512 04accd723db1b88fab80c93234f584f99138ae9c04fe6809cac59d5d4be9f4c105c288f6607ac22f019e3388ad821461e2423405353a42d3936c067219683390 WHIRLPOOL e7a6270ec7e72f4d2c75bcef984b4db7fa3aea8f4fff29d34e8b949dfac354e855af23d02e7a316b5db744b883c72e3056b196c8c1af734a4f03686691cf22ba
+DIST gnumeric-1.12.23.tar.xz 18515672 SHA256 00474cbf1e70f62062974d0beb5f65ebc45d1047bc8fd0a1133e3d9725e19551 SHA512 58f7667196cef453a24689640d21f7de20b052502fcd8f18c9abbe3ca6210d183e0bd53080ba0d6686f145400f404e75f4ed691c90801c5e2cb9f0168420cca0 WHIRLPOOL 7717082ce618adc32f20146aa86b355cbc235e8643fb7729d96c35230035cdebdf8b3aca6ba04fc53e47ce8124efe899129763384bd2172a27087482abedb30a
diff --git a/app-office/gnumeric/gnumeric-1.12.23.ebuild b/app-office/gnumeric/gnumeric-1.12.23.ebuild
new file mode 100644
index 000000000000..fce3cffa6879
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.23.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.22:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}