summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-20 14:08:45 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-20 14:52:37 +0100
commit79d3c852bd535d3f113acb42541d7ba76b81dbab (patch)
tree43e6af9ef50f61e985474dba7249419b8a3e92be /app-office/gnumeric
parentapp-office/gnumeric: Drop old (diff)
downloadgentoo-79d3c852bd535d3f113acb42541d7ba76b81dbab.tar.gz
gentoo-79d3c852bd535d3f113acb42541d7ba76b81dbab.tar.bz2
gentoo-79d3c852bd535d3f113acb42541d7ba76b81dbab.zip
app-office/gnumeric: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.27.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 8b25ce9b7412..b3a7e8668899 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,2 +1,3 @@
DIST gnumeric-1.12.24.tar.xz 18526768 SHA256 c59d5271b27366008bccb4d53ad8333da36d837003a018892f2da325c1449551 SHA512 71bed41a1b50ed57e9ab4993df8d963cb14a9f6f3fbf87d81c30f71359a23c4092daab00079936e587a118041a303c1c563bcd3f38f2aaea78a9ae5593dcdd4b WHIRLPOOL 648930de4d37d25db471fe9b639b91a64a1d1ebf1a50291ef2c79a23d4082b7249e6197467e86ce752e96699b38a7c3d86730cead7d0438c7e6605521b61e7b8
DIST gnumeric-1.12.26.tar.xz 18537376 SHA256 48250718133e998f7b2e73f71be970542e46c9096afb936dbcb152cf5394ee14 SHA512 8a9ae470d3d9df9b44783abdb9a46a63433a797936fe5a19ccc7fbafb890282af8dd12fa89ff7352cec1506a51d2775c5b8078b4d35527a7bfdb18ba269e557b WHIRLPOOL 0327ff9c8c61a3ba9c6016d2f82e70f0de3ba07fa684a985830f65ea14afd5c0b2de4d6479569a4759fd6985f892dcc5d8b350e43c9090d1043f65162b510452
+DIST gnumeric-1.12.27.tar.xz 18558196 SHA256 383a5b6eca17f0a5a0b552edcc10320fa719d10c69c7b6fb29d5a11808f1d1c9 SHA512 7111c311bc7e0ac8e6ad016ff68667b215c1d0aec20d26a573a4c14b4ca3c3fb3002bf6ff15d6472d635ef6f6eadff7532dd65ea00d531a8e15ff24b3d261554 WHIRLPOOL a7a93f4c37f5b30d626c796d516d7ff6bca92845081bc0b92f0f539c023853f095acaf2876e668c650b7ae3375604dc372fdeb9789e8088e6e116306515641f4
diff --git a/app-office/gnumeric/gnumeric-1.12.27.ebuild b/app-office/gnumeric/gnumeric-1.12.27.ebuild
new file mode 100644
index 000000000000..7b107396d9bd
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.27.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.27:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}