summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2017-12-20 11:26:04 +0100
committerMarek Szuba <marecki@gentoo.org>2017-12-20 11:36:29 +0100
commit6052378094ebf81f0525ef2e9f4396ef95edb7cb (patch)
tree774d9f9081a1a81a9bc21b93eeab57fd4ef739a6 /app-office/impressive
parentmedia-video/ffmpeg: bump to 3.4.1 (diff)
downloadgentoo-6052378094ebf81f0525ef2e9f4396ef95edb7cb.tar.gz
gentoo-6052378094ebf81f0525ef2e9f4396ef95edb7cb.tar.bz2
gentoo-6052378094ebf81f0525ef2e9f4396ef95edb7cb.zip
app-office/impressive: bump to version 0.11.2 and EAPI 6
app-text/mupdf is now a hard dependency because according to the upstream maintainer, viewing PDF files will simply not work without it. It has also taken over most of the jobs previously handled by app-text/pdftk, which is now an optional enhancement rather than a dependency - it is masked in recent profiles all it is used for when mupdf is present is extraction of PDF page titles. Closes: https://bugs.gentoo.org/579078 Suggested-by: Martin Fiedler <martin.fiedler@gmx.net> Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/Manifest1
-rw-r--r--app-office/impressive/impressive-0.11.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index cc9db775b3cc..01894d7e827b 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1,2 +1,3 @@
DIST Impressive-0.10.5.tar.gz 166707 BLAKE2B 2d5ef9d05d82a22af037fda0e0b01252d513ee0686f9ab21f1d24cf86b4e0a5043aaf7f16b3d9d8a6773b110f716948c184a058845d7595155a40410821c8ccf SHA512 3939188d45ac7a617a56be72e72c98923c23073bee2c3c1b7b81fc2e26ce415ceffdf5456d754f921e488181d8edb7df96ad90e6923b2425c49e38da75c02f20
DIST Impressive-0.11.0b.tar.gz 195138 BLAKE2B daa8e7bc17ec028a9c858688182a4cd6426004aaec24b7ea1574cd415a7f43f0d8a0ae43b01089d66a66c16b316439454341a3f6c2d366768a351ba2fff85b93 SHA512 c4038ed7b71ac79078922ee0e24ce3bef4b0384d8d468291f0283266fe8a849825f5798ec1260e40ac12659a8a7cf5325e3aca0e2475b1c483d3ce830f4bc70f
+DIST Impressive-0.11.2.tar.gz 198391 BLAKE2B e0157a910b61c7dbe0796193b3d18f533210de50568d835e5204a848a5ac4978ab228b633d5137fb068af09a88d0c50fc2dbbb02b9b0d1a32a99f9de220ac1de SHA512 cabb52612f65ddadfb080e3db6417680a1aa9724fe45d8b78a1206b6508a8b60c5e5a7c218ff0f90e62adcd498aabe625837164fc547604dfd7aba425db87dd6
diff --git a/app-office/impressive/impressive-0.11.2.ebuild b/app-office/impressive/impressive-0.11.2.ebuild
new file mode 100644
index 000000000000..14227452dabf
--- /dev/null
+++ b/app-office/impressive/impressive-0.11.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ app-text/mupdf
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(
+ changelog.txt
+ demo.pdf
+)
+HTML_DOCS=(
+ impressive.html
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ elog "The experience with ${PN} can be enhanced by folowing packages:"
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "sound and video playback" media-video/mplayer2
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}