summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-02-03 17:18:09 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-09 01:16:02 +1100
commit086d38b7bccc6890437cf096ba0440f968584ea6 (patch)
tree8bb6f06f5a47bcc2ecab999e99411106de1691a1 /app-office
parentx11-misc/lightdm-kde: add missing dependency (diff)
downloadgentoo-086d38b7bccc6890437cf096ba0440f968584ea6.tar.gz
gentoo-086d38b7bccc6890437cf096ba0440f968584ea6.tar.bz2
gentoo-086d38b7bccc6890437cf096ba0440f968584ea6.zip
app-office/akonadi-server: Add 1.13.1 snapshot
Diffstat (limited to 'app-office')
-rw-r--r--app-office/akonadi-server/Manifest1
-rw-r--r--app-office/akonadi-server/akonadi-server-1.13.1_pre20160203-r1.ebuild134
-rw-r--r--app-office/akonadi-server/files/akonadi-server-1.13.1-mysql.conf.patch38
3 files changed, 173 insertions, 0 deletions
diff --git a/app-office/akonadi-server/Manifest b/app-office/akonadi-server/Manifest
index 67ce388c81e1..ccf4860123f7 100644
--- a/app-office/akonadi-server/Manifest
+++ b/app-office/akonadi-server/Manifest
@@ -1 +1,2 @@
DIST akonadi-1.13.0.tar.bz2 294198 SHA256 8c7f690002ea22c139f3a64394aef2e816e00ca47fd971af7d54a66087356dd2 SHA512 4bf2026c3807b5493c9f63d0c2bff2e6db00fbe97a4e2c2f707aaa3bf4a848b70dd9657d8fa1743690e8eeefd967de4895c1329c6bb817a1d023fe398285222f WHIRLPOOL edc18247dd864af48395f4e3187f6a52cdaf4737959b317e3decb10caf138b97258a661eeb11a2ad11f2365fdd053a7c6fe63097ba71c24a12417ee71de54afb
+DIST akonadi-server-1.13.1_pre20160203.tar.gz 384556 SHA256 4243b32e529be6aadc38dc4463cb6e7cede9442c05cfc04ba679dde28f37aa96 SHA512 0ef8213f504ad1e500a2c1ce19a7575cd1fd8b7ffc7e5fb0bd2437639d8c458c47bbfea7734fcd3e200136a661331dde32af0b064f0b25d324138ce6e35d15f3 WHIRLPOOL 69eff1889a19f8d5714d7e71a106871172cd25c651ea30046ab81270cf7e46c7a1983cf20fd8d5fd8ad243d70e881be705d57b0b93b54248d086e7b253a4873a
diff --git a/app-office/akonadi-server/akonadi-server-1.13.1_pre20160203-r1.ebuild b/app-office/akonadi-server/akonadi-server-1.13.1_pre20160203-r1.ebuild
new file mode 100644
index 000000000000..cff46c62651f
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.13.1_pre20160203-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI=( "git://anongit.kde.org/akonadi" )
+ SRC_URI=""
+ KEYWORDS=""
+else
+ if [[ ${PV} = *_pre* ]]; then
+ COMMIT_ID="18ed37d89b8185ac15a8bfe245de8a88d17f2c64"
+ SRC_URI="https://quickgit.kde.org/?p=akonadi.git&a=snapshot&h=${COMMIT_ID}&fmt=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN/-server/}"
+ else
+ SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+ S="${WORKDIR}/${P/-server/}"
+ fi
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="https://pim.kde.org/akonadi"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+mysql postgres sqlite test"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-qt/qtcore-4.8.5:4
+ >=dev-qt/qtdbus-4.8.5:4
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtsql-4.8.5:4[mysql?,postgres?]
+ >=dev-qt/qttest-4.8.5:4
+ x11-misc/shared-mime-info
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+ test? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.13.0-mysql56-crash.patch"
+ "${FILESDIR}/${PN}-1.13.1-mysql.conf.patch"
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) \
+ && die "Sorry, but gcc-4.6 and earlier won't work (see bug #520102)."
+ fi
+}
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about MySQL is recommend by upstream
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream. PostgreSQL"
+ ewarn "is also known to work very well but requires manual dump and import on major"
+ ewarn "upgrades of the DB."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_QSQLITE_IN_QT_PREFIX=ON
+ -DWITH_SOPRANO=FALSE
+ -DAKONADI_BUILD_TESTS=$(usex test)
+ -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
+ -DQT5_BUILD=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ export $(dbus-launch)
+ cmake-utils_src_test
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/app-office/akonadi-server/files/akonadi-server-1.13.1-mysql.conf.patch b/app-office/akonadi-server/files/akonadi-server-1.13.1-mysql.conf.patch
new file mode 100644
index 000000000000..a090636e7256
--- /dev/null
+++ b/app-office/akonadi-server/files/akonadi-server-1.13.1-mysql.conf.patch
@@ -0,0 +1,38 @@
+From: Daniel Vrátil <dvratil@kde.org>
+Date: Tue, 16 Feb 2016 17:26:22 +0000
+Subject: Drop mysql.conf option removed in MySQL 5.7
+X-Git-Url: http://quickgit.kde.org/?p=akonadi.git&a=commitdiff&h=9a9f7eaa38023f70c6fa85a87359a487ccf7a48c
+---
+Drop mysql.conf option removed in MySQL 5.7
+
+innodb_additional_mem_pool_size option has been deprecated in MySQL 5.6
+and removed in 5.7 so MySQL will no longer start it the option is present
+in mysql.conf.
+
+The option still seems to be supported by MariaDB, but the default value
+we had in the mysql.conf was below the minimum allowed value, so the harm
+in removing the option for MariaDB should be minimal.
+
+If options supported by MySQL and MariaDB begin to diverge more in the future
+we might consider having separate config files for each database.
+
+* 2016-02-21: Adjusted path for 1.13 branch
+---
+
+
+--- a/server/src/storage/mysql-global.conf
++++ b/server/src/storage/mysql-global.conf
+@@ -37,9 +37,9 @@
+ # use InnoDB for transactions and better crash recovery
+ default_storage_engine=innodb
+
+-# memory pool InnoDB uses to store data dictionary information and other internal data structures (default:1M)
+-# Deprecated in MySQL >= 5.6.3
+-innodb_additional_mem_pool_size=1M
++# memory pool InnoDB uses to store data dictionary information and other internal data structures (default:8M)
++# Deprecated in MySQL >= 5.6.3, removed in 5.7 (works in MariaDB)
++# innodb_additional_mem_pool_size=8M
+
+ # memory buffer InnoDB uses to cache data and indexes of its tables (default:128M)
+ # Larger values means less I/O
+