summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-27 23:36:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-28 02:19:37 +0100
commit2b37981a42b6f9259a31f4b1269dadcf6a36bb95 (patch)
tree5e030a62e1cafe7493ccb9c6390792a3a5e9a6ca /app-office
parentprofiles/package.mask: cleanup (diff)
downloadgentoo-2b37981a42b6f9259a31f4b1269dadcf6a36bb95.tar.gz
gentoo-2b37981a42b6f9259a31f4b1269dadcf6a36bb95.tar.bz2
gentoo-2b37981a42b6f9259a31f4b1269dadcf6a36bb95.zip
app-office/calligra: 3.1.0 version bump
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra/Manifest2
-rw-r--r--app-office/calligra/calligra-3.1.0.ebuild241
-rw-r--r--app-office/calligra/files/calligra-3.1.0-no-arch-detection.patch17
-rw-r--r--app-office/calligra/metadata.xml1
4 files changed, 261 insertions, 0 deletions
diff --git a/app-office/calligra/Manifest b/app-office/calligra/Manifest
index 776ebb77289d..8cf6fbe018a9 100644
--- a/app-office/calligra/Manifest
+++ b/app-office/calligra/Manifest
@@ -1 +1,3 @@
DIST calligra-3.0.1.tar.xz 60764344 BLAKE2B e264f1eb5928d2f11fba9c9b71a77d2685230b9128105264d109d3aca51f32a814795dd04f5f8fb980dce4fa4d4365c4073b35c2abb8933c906238bc0b25aef2 SHA512 ec17d007262d598e16045c6c75f8a37dfdf73b980b02ae9bea20282cbd4dd53202f62fc4d8bd84484193a501859c2150079a76d83c1638d8449f41526df57ee0
+DIST calligra-3.1.0.tar.xz 58037392 BLAKE2B b933012fe0031f4d6eac626054e7fb248f85635e5873224328d30f9aed31dce0a0a49f99cf6eea9c232477400af1d16ffc4dae483cdfd5081720434e95684e50 SHA512 ad1b689a5b36deafcf6985d4a0a1e8148d10e19fb4a0be8343c6e1d24146b9a8ffa0890ab5bbb21816b3134d21150b57f6159db1a30cc54c0fde5bf7bdf4537b
+DIST calligraplan-3.1.0.tar.xz 3617600 BLAKE2B af45aa28529c18c9fa9fae2b7c03ea1b795d3fec3fd44dbcc4ed056a4b1b843b10cb8a9ad6dab319775a7d7032520721a4719605859dd60100a19eafdcb621ed SHA512 a8ccc6ee2f0381b811926a296122464bdb79aad7c75ff0f7a554e4596165ff7fd7ef62c9af9232ea36542d6b538446c8920fe77cbbe7ffacdf6e6b99a1b68156
diff --git a/app-office/calligra/calligra-3.1.0.ebuild b/app-office/calligra/calligra-3.1.0.ebuild
new file mode 100644
index 000000000000..b053f117b3ad
--- /dev/null
+++ b/app-office/calligra/calligra-3.1.0.ebuild
@@ -0,0 +1,241 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CHECKREQS_DISK_BUILD="4G"
+KDE_APPS_MINIMAL="17.12.0"
+KDE_HANDBOOK="forceoptional"
+KDE_PO_DIRS="po plan/po"
+KDE_TEST="forceoptional"
+inherit check-reqs kde5 versionator
+
+DESCRIPTION="KDE Office Suite"
+HOMEPAGE="https://www.calligra.org/"
+[[ ${KDE_BUILD_TYPE} == release ]] && \
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz
+ calligra_features_plan? ( mirror://kde/stable/${PN}/${PV}/${PN}plan-${PV}.tar.xz )"
+
+LICENSE="GPL-2"
+
+[[ ${KDE_BUILD_TYPE} == release ]] && \
+KEYWORDS="~amd64 ~x86"
+
+CAL_FTS=( karbon plan sheets words )
+
+IUSE="activities +crypt +fontconfig gemini gsl import-filter +lcms okular openexr +pdf
+ phonon pim spacenav +truetype X $(printf 'calligra_features_%s ' ${CAL_FTS[@]})
+ calligra_experimental_features_stage"
+
+# TODO: Not packaged: Cauchy (https://bitbucket.org/cyrille/cauchy)
+# Required for the matlab/octave formula tool
+# FIXME: Disabled by upstream for good reason
+# Crashes plan (https://bugs.kde.org/show_bug.cgi?id=311940)
+# $(add_kdeapps_dep akonadi)
+# $(add_kdeapps_dep akonadi-contacts)
+# Currently upstream-disabled in plan
+# =dev-libs/kproperty-3.0*:5
+# =dev-libs/kreport-3.0*:5
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kross)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep designer)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-lang/perl
+ sys-libs/zlib
+ virtual/libiconv
+ activities? ( $(add_frameworks_dep kactivities) )
+ crypt? ( app-crypt/qca:2[qt5] )
+ fontconfig? ( media-libs/fontconfig )
+ gemini? ( $(add_qt_dep qtdeclarative 'widgets') )
+ gsl? ( sci-libs/gsl )
+ import-filter? (
+ $(add_frameworks_dep khtml)
+ app-text/libetonyek
+ app-text/libodfgen
+ app-text/libwpd:*
+ app-text/libwpg:*
+ >=app-text/libwps-0.4
+ dev-libs/librevenge
+ media-libs/libvisio
+ )
+ lcms? (
+ media-libs/ilmbase:=
+ media-libs/lcms:2
+ )
+ openexr? ( media-libs/openexr )
+ pdf? ( app-text/poppler:=[qt5] )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ spacenav? ( dev-libs/libspnav )
+ truetype? ( media-libs/freetype:2 )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+ calligra_experimental_features_stage? (
+ $(add_qt_dep qtwebkit)
+ okular? ( $(add_kdeapps_dep okular) )
+ )
+ calligra_features_plan? (
+ $(add_frameworks_dep khtml)
+ $(add_kdeapps_dep kholidays)
+ dev-libs/kdiagram:5
+ pim? (
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ )
+ )
+ calligra_features_sheets? ( dev-cpp/eigen:3 )
+ calligra_features_words? (
+ dev-libs/libxslt
+ okular? ( $(add_kdeapps_dep okular) )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+ x11-misc/shared-mime-info
+ test? ( $(add_frameworks_dep threadweaver) )
+"
+RDEPEND="${COMMON_DEPEND}
+ calligra_features_karbon? ( media-gfx/pstoedit[plotutils] )
+ !app-office/calligra:4
+ !app-office/calligra-l10n:4
+"
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${P}-no-arch-detection.patch )
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ kde5_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_prepare() {
+ if use calligra_features_plan && [[ ${KDE_BUILD_TYPE} == release ]]; then
+ mv ../${PN}plan-${PV} plan || die
+ sed -e "/add_subdirectory(plan)/s/#//" \
+ -e "/^calligra_disable_product(APP_PLAN/s/^/#/" \
+ -i CMakeLists.txt || die
+ fi
+ kde5_src_prepare
+
+ if ! use test; then
+ sed -e "/add_subdirectory( *benchmarks *)/s/^/#DONT/" \
+ -i libs/pigment/CMakeLists.txt || die
+ fi
+
+ # Unconditionally disable deprecated deps (required by QtQuick1)
+ punt_bogus_dep Qt5 Declarative
+ punt_bogus_dep Qt5 OpenGL
+
+ if ! use calligra_experimental_features_stage; then
+ punt_bogus_dep Qt5 WebKitWidgets
+ punt_bogus_dep Qt5 WebKit
+ fi
+
+ # Hack around the excessive use of CMake macros
+ if use okular && ! use calligra_features_words; then
+ sed -i -e "/add_subdirectory( *okularodtgenerator *)/ s/^/#DONT/" \
+ extras/CMakeLists.txt || die "Failed to disable OKULAR_GENERATOR_ODT"
+ fi
+
+ if use okular && ! use calligra_experimental_features_stage; then
+ sed -i -e "/add_subdirectory( *okularodpgenerator *)/ s/^/#DONT/" \
+ extras/CMakeLists.txt || die "Failed to disable OKULAR_GENERATOR_ODP"
+ fi
+}
+
+src_configure() {
+ local cal_ft myproducts
+
+ # applications
+ for cal_ft in ${CAL_FTS[@]}; do
+ if use calligra_features_${cal_ft} ; then
+ myproducts+=( "${cal_ft^^}" )
+ fi
+ done
+
+ [[ ${KDE_BUILD_TYPE} == release ]] && \
+ use calligra_experimental_features_stage && \
+ myproducts+=( CALLIGRA_FEATURES_STAGE )
+
+ use lcms && myproducts+=( PLUGIN_COLORENGINES )
+ use spacenav && myproducts+=( PLUGIN_SPACENAVIGATOR )
+
+ local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
+
+ if [[ ${KDE_BUILD_TYPE} == release ]] ; then
+ mycmakeargs+=(
+ -DRELEASE_BUILD=ON
+ -DBUILD_UNMAINTAINED=$(usex calligra_experimental_features_stage)
+ )
+ fi
+
+ mycmakeargs+=(
+ -DPACKAGERS_BUILD=OFF
+ -DWITH_Iconv=ON
+ $(cmake-utils_use_find_package activities KF5Activities)
+ -DWITH_Qca-qt5=$(usex crypt)
+ -DWITH_Fontconfig=$(usex fontconfig)
+ $(cmake-utils_use_find_package gemini Libgit2)
+ $(cmake-utils_use_find_package gemini Qt5QuickWidgets)
+ -DWITH_GSL=$(usex gsl)
+ -DWITH_LibEtonyek=$(usex import-filter)
+ -DWITH_LibOdfGen=$(usex import-filter)
+ -DWITH_LibRevenge=$(usex import-filter)
+ -DWITH_LibVisio=$(usex import-filter)
+ -DWITH_LibWpd=$(usex import-filter)
+ -DWITH_LibWpg=$(usex import-filter)
+ -DWITH_LibWps=$(usex import-filter)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ $(cmake-utils_use_find_package pim KF5CalendarCore)
+ $(cmake-utils_use_find_package pim KF5Contacts)
+ -DWITH_LCMS2=$(usex lcms)
+ -DWITH_Okular5=$(usex okular)
+ -DWITH_OpenEXR=$(usex openexr)
+ -DWITH_Poppler=$(usex pdf)
+ -DWITH_Eigen3=$(usex calligra_features_sheets)
+ -ENABLE_CSTESTER_TESTING=$(usex test)
+ -DWITH_Freetype=$(usex truetype)
+ )
+
+ kde5_src_configure
+}
diff --git a/app-office/calligra/files/calligra-3.1.0-no-arch-detection.patch b/app-office/calligra/files/calligra-3.1.0-no-arch-detection.patch
new file mode 100644
index 000000000000..aa83ba1a3010
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.1.0-no-arch-detection.patch
@@ -0,0 +1,17 @@
+Avoid automagic CXXFLAG detection courtesy of dev-libs/vc.
+
+Gentoo-bug: 584118
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -617,10 +617,6 @@
+ endif()
+ endmacro()
+
+- if (NOT PACKAGERS_BUILD)
+- # Optimize the whole Calligra for current architecture
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Vc_DEFINITIONS}")
+- endif ()
+ endif()
+ set(CMAKE_MODULE_PATH ${OLD_CMAKE_MODULE_PATH} )
+
diff --git a/app-office/calligra/metadata.xml b/app-office/calligra/metadata.xml
index d600cd47a36a..575f0b0a9176 100644
--- a/app-office/calligra/metadata.xml
+++ b/app-office/calligra/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<use>
<flag name="activities">Enable kactivities support</flag>
+ <flag name="gemini">Enable tablet and 2:1 devices support</flag>
<flag name="import-filter">Enable support for various import filter file formats like WordPerfect, Visio and Apple Keynote</flag>
<flag name="lcms">Build colorengine plugins using <pkg>media-libs/lcms</pkg></flag>
<flag name="okular">Enable bindings for <pkg>kde-apps/okular</pkg></flag>