summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 12:33:13 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:40:36 +0200
commit89d1c5fa40b5e375f3f26fa7b525bf15f520bcac (patch)
tree7a22f3302bd47f54a70631f60c4762b3a5567dbd /app-office
parentapp-office/gnumeric: Drop old (diff)
downloadgentoo-89d1c5fa40b5e375f3f26fa7b525bf15f520bcac.tar.gz
gentoo-89d1c5fa40b5e375f3f26fa7b525bf15f520bcac.tar.bz2
gentoo-89d1c5fa40b5e375f3f26fa7b525bf15f520bcac.zip
app-office/gnumeric: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.28.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 20f59006cb3b..85ad370d8cdb 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.27.tar.xz 18558196 SHA256 383a5b6eca17f0a5a0b552edcc10320fa719d10c69c7b6fb29d5a11808f1d1c9 SHA512 7111c311bc7e0ac8e6ad016ff68667b215c1d0aec20d26a573a4c14b4ca3c3fb3002bf6ff15d6472d635ef6f6eadff7532dd65ea00d531a8e15ff24b3d261554 WHIRLPOOL a7a93f4c37f5b30d626c796d516d7ff6bca92845081bc0b92f0f539c023853f095acaf2876e668c650b7ae3375604dc372fdeb9789e8088e6e116306515641f4
+DIST gnumeric-1.12.28.tar.xz 18730404 SHA256 02d4ad13389e51f24638a0a59dbfb870ec8120efc453b2dca8804167f2b94dbb SHA512 9f2ecfe47a16f02edec3038f3deb67200bd4280d6e49709c4c1cbef95857bfd10b0b1789345216fa0ad4018d4bce8284d37c294dc0fddb62094283ec5a22cf54 WHIRLPOOL cc7f486b4fa404c9f8fe68c5cc3330641a10adbd922ac8f1c851aaa41c0bf1052c75879eb7222f47be5412afb5e5072befa15dc0df38c4defb48f513c0ff15d0
diff --git a/app-office/gnumeric/gnumeric-1.12.28.ebuild b/app-office/gnumeric/gnumeric-1.12.28.ebuild
new file mode 100644
index 000000000000..107797145439
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.28.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.28:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}