summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-08-15 08:47:57 +0300
committerStefan Strogin <steils@gentoo.org>2020-08-15 08:49:41 +0300
commit17e61fb1aa62d3de6ae10b48689a9f58eb74cd1a (patch)
tree4d6b974cde45630c6e31a91a7dada94b3f640a55 /app-pda/libimobiledevice
parentwww-servers/puma: cleanup (diff)
downloadgentoo-17e61fb1aa62d3de6ae10b48689a9f58eb74cd1a.tar.gz
gentoo-17e61fb1aa62d3de6ae10b48689a9f58eb74cd1a.tar.bz2
gentoo-17e61fb1aa62d3de6ae10b48689a9f58eb74cd1a.zip
app-pda/libimobiledevice: add patch for LibreSSL
Closes: https://bugs.gentoo.org/732908 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'app-pda/libimobiledevice')
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch25
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild2
2 files changed, 27 insertions, 0 deletions
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch
new file mode 100644
index 000000000000..0957c9132cbf
--- /dev/null
+++ b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch
@@ -0,0 +1,25 @@
+From 170e1c445e8c930f4ee9dddfb9f1bcf24c089962 Mon Sep 17 00:00:00 2001
+From: Nikias Bassen <nikias@gmx.li>
+Date: Thu, 6 Aug 2020 20:43:08 +0200
+Subject: [PATCH] idevice: Fix build with LibreSSL
+
+Upstream-Status: Accepted
+[https://github.com/libimobiledevice/libimobiledevice/commit/170e1c445e8c930f4ee9dddfb9f1bcf24c089962]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ src/idevice.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/idevice.c b/src/idevice.c
+index fea1e03f..47c9ab4d 100644
+--- a/src/idevice.c
++++ b/src/idevice.c
+@@ -1015,7 +1015,7 @@ LIBIMOBILEDEVICE_API idevice_error_t idevice_connection_enable_ssl(idevice_conne
+ return ret;
+ }
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ SSL_CTX_set_security_level(ssl_ctx, 0);
+ #endif
+
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild
index 2a6307967357..8ff61a7c4d2e 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild
@@ -46,6 +46,8 @@ BDEPEND="
BUILD_DIR="${S}_build"
+PATCHES=( "${FILESDIR}"/${P}-libressl.patch )
+
src_prepare() {
default
eautoreconf