summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-27 21:44:21 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-27 21:44:27 -0500
commit40ff5ce7db81c643f119210ac99a38e835e3ff5c (patch)
treec88e8ecce0e4fe1a9cc087a4a63d6c6e95f7ec72 /app-portage/portage-utils
parentapp-portage/portage-utils: drop old versions (diff)
downloadgentoo-40ff5ce7db81c643f119210ac99a38e835e3ff5c.tar.gz
gentoo-40ff5ce7db81c643f119210ac99a38e835e3ff5c.tar.bz2
gentoo-40ff5ce7db81c643f119210ac99a38e835e3ff5c.zip
app-portage/portage-utils: version bump to 0.60
Diffstat (limited to 'app-portage/portage-utils')
-rw-r--r--app-portage/portage-utils/Manifest1
-rw-r--r--app-portage/portage-utils/portage-utils-0.60.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index 016789adf8c7..048db3fe1298 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1 +1,2 @@
DIST portage-utils-0.56.tar.xz 513832 SHA256 4df7323fb2667dd9bcee0f2d169c01ed8600aa6196118e6cd3a10cfe99852bbf SHA512 f2136a7df4cd91499b135fbf000f81a71177d5a39b4da2db484ab0f9492d152eaa72a5fee0e56d4b58611462e251905e554f5e41890a749f05d19e50c16c77b6 WHIRLPOOL af0a96ca3bf2dd39335317829aa8aff110a63042c415368400977e974cc21163da7eb76f7d53fcd05e133fd8a8568255ba022a32f1b174bda0dcb15b5f1476b9
+DIST portage-utils-0.60.tar.xz 519424 SHA256 d5e4a7384321d21d0aa484fcd30768dbce557e9c97a98cd2723d3eb75b82f503 SHA512 80355b31d49ac0f47c0a05071584608bd5fc0b8a98ab9025cb0a3bc8c18e318fbc60ff33e6834cd4f0ad159c2eb7f63d0d9cb61d4c86cee473215670ebba5694 WHIRLPOOL ec6d2bc1b164a7baff83019455de91483a98401f052153e152cef3733d041e71ca2f4333c9281aa593ee962d0e42b2d4f72f0d04e13982cbb25518f3bd5ca66d
diff --git a/app-portage/portage-utils/portage-utils-0.60.ebuild b/app-portage/portage-utils/portage-utils-0.60.ebuild
new file mode 100644
index 000000000000..4b100d0e1a38
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.60.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="small and fast portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+RDEPEND="dev-libs/iniparser:0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ static? ( dev-libs/iniparser:0[static-libs] )"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux || \
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf --with-eprefix="${EPREFIX}"
+ else
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ emake NLS=$(usex nls)
+}
+
+src_install() {
+ default
+
+ exeinto /etc/portage/bin
+ doexe "${FILESDIR}"/post_sync
+ insinto /etc/portage/postsync.d
+ doins "${FILESDIR}"/q-reinitialize
+
+ # Portage fixes shebangs, we just need to fix the paths in the files
+ sed -i \
+ -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
+ "${ED}"/etc/portage/bin/post_sync \
+ "${ED}"/etc/portage/postsync.d/q-reinitialize || die
+}
+
+pkg_preinst() {
+ # preserve +x bit on postsync files #301721
+ local x
+ pushd "${ED}" >/dev/null
+ for x in etc/portage/postsync.d/* ; do
+ [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
+ done
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
+ elog "If you wish for it to be automatically run at the end of every --sync:"
+ elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
+ elog "Normally this should only take a few seconds to run but file systems"
+ elog "such as ext3 can take a lot longer. To disable, simply do:"
+ elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
+ fi
+}