summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-03-28 00:50:10 -0700
committerZac Medico <zmedico@gentoo.org>2018-03-28 00:57:39 -0700
commit8ff7e057a7d5f36b941a7a28a156f70d35783e6e (patch)
treee21553c75d2cc94fc7d0accee08cbd011c545b2b /app-portage/repoman/repoman-2.3.7.ebuild
parentsys-apps/portage: version bump to 2.3.25 (diff)
downloadgentoo-8ff7e057a7d5f36b941a7a28a156f70d35783e6e.tar.gz
gentoo-8ff7e057a7d5f36b941a7a28a156f70d35783e6e.tar.bz2
gentoo-8ff7e057a7d5f36b941a7a28a156f70d35783e6e.zip
app-portage/repoman: version bump to 2.3.7
#552720 - allow https for metadata.dtd URI Package-Manager: Portage-2.3.25_p1, Repoman-2.3.7
Diffstat (limited to 'app-portage/repoman/repoman-2.3.7.ebuild')
-rw-r--r--app-portage/repoman/repoman-2.3.7.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-portage/repoman/repoman-2.3.7.ebuild b/app-portage/repoman/repoman-2.3.7.ebuild
new file mode 100644
index 000000000000..51f20a852af7
--- /dev/null
+++ b/app-portage/repoman/repoman-2.3.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.3.25[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "This release of repoman is from the new portage/repoman split"
+ einfo "release code base."
+ einfo "This new repoman code base is still being developed. So its API's"
+ einfo "are not to be considered stable and are subject to change."
+ einfo "The code released has been tested and considered ready for use."
+ einfo "This however does not guarantee it to be completely bug free."
+ einfo "Please report any bugs you may encounter."
+ einfo ""
+}