summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-05-30 12:26:13 +0200
committerFabian Groffen <grobian@gentoo.org>2019-05-30 12:26:38 +0200
commit3aeaba5688ef7a40803aedc6b3f8d6c51847bd61 (patch)
tree2042622cbeb1291eec613e4787be7462b72f4fa0 /app-portage
parentprofiles: start masking texlive 2019 before adding (diff)
downloadgentoo-3aeaba5688ef7a40803aedc6b3f8d6c51847bd61.tar.gz
gentoo-3aeaba5688ef7a40803aedc6b3f8d6c51847bd61.tar.bz2
gentoo-3aeaba5688ef7a40803aedc6b3f8d6c51847bd61.zip
app-portage/portage-utils: add RC for 0.80
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-utils/Manifest1
-rw-r--r--app-portage/portage-utils/portage-utils-0.80_pre20190530.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index 1f034f2af8ec..f639c7069a19 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1,2 +1,3 @@
DIST portage-utils-0.62.tar.xz 527216 BLAKE2B ac8331b74998ddb86db55a937992447bccf60611cc259ceb5fe79918c1a43b6dc4633e4ad64462e2df5c39e8d8aa193bd57ab24dcd714e088357eb3cb177e972 SHA512 71b2888cef1bf7549c3829cc7d4bbe2e99a711434bae4fb78c55b9c37815b61623518f19ab87db30f533d771398933c085640dc7c8ffcedf87a70ac702a52fa1
DIST portage-utils-0.74.tar.xz 1587792 BLAKE2B 7c4588e3d44266a5260df42cc685aa03c584248e9970956033e4191a7a842a4b2162110ac99c2bb18645aaafc6ae6ee960e9b26ba0a8863497911eef1e943f64 SHA512 cd3f44c135b3d44e15a95eed41281fce62f225a9d05d5d5bb1be230b2d59cdb87755f011b313a9ec32e4cafdf3b3979c4ef423365edd7dcc472ca2e38c09c83e
+DIST portage-utils-0.80_pre20190530.tar.xz 1758056 BLAKE2B 2d595db45ecfe125da80924b145be4d1ebfcda09afb3dd39c4dfa084b4113e162637cbfc8f3362554b39de55339462de9714cbef6194816b7340e77c335d3432 SHA512 720bb057e6428d51832d1e92e8ae1fb4d7b6c1f407f78656ef4853822b08525849614f7f760a395385d69400c08bf103eb05308b87bd9f7189cac53e95e93583
diff --git a/app-portage/portage-utils/portage-utils-0.80_pre20190530.ebuild b/app-portage/portage-utils/portage-utils-0.80_pre20190530.ebuild
new file mode 100644
index 000000000000..5ff83758116d
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.80_pre20190530.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small and fast Portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls static openmp +qmanifest"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc ~ppc-aix ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+RDEPEND="dev-libs/iniparser:0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ static? ( dev-libs/iniparser:0[static-libs] )
+ qmanifest? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ app-crypt/libb2
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ app-crypt/gpgme
+ )
+ "
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --with-eprefix="${EPREFIX}" \
+ $(use_enable qmanifest) \
+ $(use_enable openmp)
+}