summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-13 12:19:02 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-13 12:37:36 +0100
commit40e5ce570d21987604088c0a30c4071bc7efe7e5 (patch)
treee48870bf613458a3dbe8aeec0b9dcd55c2de27d4 /app-portage
parentsys-kernel/vanilla-sources: Automated version bump to 4.14.19 - remove old. (diff)
downloadgentoo-40e5ce570d21987604088c0a30c4071bc7efe7e5.tar.gz
gentoo-40e5ce570d21987604088c0a30c4071bc7efe7e5.tar.bz2
gentoo-40e5ce570d21987604088c0a30c4071bc7efe7e5.zip
app-portage/gemato: Bump to 11.2
Bump to 11.2. The new version improves Python 2 compatibility, adds a workaround for PyPy misbehavior and adds a new utility commands that could be useful to debug verification failures. Closes: https://bugs.gentoo.org/646368
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-11.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 2711fb7c8e0d..202e1041730d 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,3 +1,4 @@
DIST gemato-10.3.tar.gz 63279 BLAKE2B 317c98c3989399e3a87cd5452edc509da86b17ecb41d295feca4071141d3ff1ba95a86544d64c786726f2148a899c1597020dde3513a913b1bc1811e2117337e SHA512 dd2b47238ac0707984358bd763ce0dfb23d8b09561939d22aae2e60386de388af9c5e67faa89a6ab9da4f0b334ee8486eeda66e5eb83bd2a26241b8a2b88128d
DIST gemato-11.0.tar.gz 64123 BLAKE2B c1020368eca1f8914c2377e23b27e953e06268e70754e2265af6d31defb2960263371aa6cbfb22b046d1bbdf549c948b62858d09055e8813fc9148a28c264a81 SHA512 c9ba297950a96fc7c07f88b8dcda33c3f351043ca062c354425be43ce4915b5ee37d6a28122797cfc01152546e72eda647e27f764b53345bfef87b292dd893e7
DIST gemato-11.1.tar.gz 64338 BLAKE2B 672816956115bcf9a8f4832d8ca6af290d5ea2db213fbf485e969ec6f1c79e1f9a42590a8b88e7c204608ee8a1e2d2e7935b02a046fc08730dac667e5e371d09 SHA512 518f2728564a70e1758c3ee1290b01a27815fb51a64e632ad08fc6481becc0bf03756270aa2eed3fc3403557226c00a3f6099e73cd110532455ead515b37e109
+DIST gemato-11.2.tar.gz 66260 BLAKE2B 94b7f4a6718314e767676589b10addb05d52133e7e860b257cb558f31ffea27c88bc06bfd2fed7268bfd34179aaee77a9a6e7ffd3bd3fc4e43987e719d809f1e SHA512 61c5a8dccbb99c5ff7880a4e3d26a3f468a70e9622b7aebf53d312cc7105ec7c9abb04d00acdfa9cac29c4779b267abc35074272b7c921f8221d18383b0d445c
diff --git a/app-portage/gemato/gemato-11.2.ebuild b/app-portage/gemato/gemato-11.2.ebuild
new file mode 100644
index 000000000000..6dd1dc95ea59
--- /dev/null
+++ b/app-portage/gemato/gemato-11.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}