summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-06-19 18:17:24 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-19 18:18:44 -0700
commit6a639af12aa9535a903e7a13a88a71e3cd0acd1d (patch)
treeea20d4e33b6c0d027c3f8d20175580e60c87622b /app-portage
parentapp-portage/repoman: Remove old versions (diff)
downloadgentoo-6a639af12aa9535a903e7a13a88a71e3cd0acd1d.tar.gz
gentoo-6a639af12aa9535a903e7a13a88a71e3cd0acd1d.tar.bz2
gentoo-6a639af12aa9535a903e7a13a88a71e3cd0acd1d.zip
app-portage/repoman: Bump to version 2.3.15
#688278 Accept 'Gentoo Foundation' copyright for old ebuilds Closes: https://bugs.gentoo.org/688278 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/repoman/Manifest1
-rw-r--r--app-portage/repoman/repoman-2.3.15.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-portage/repoman/Manifest b/app-portage/repoman/Manifest
index d8a8e0c454c9..3cbd2bfe39d6 100644
--- a/app-portage/repoman/Manifest
+++ b/app-portage/repoman/Manifest
@@ -1,2 +1,3 @@
DIST repoman-2.3.11.tar.bz2 86807 BLAKE2B f5bf8e9b7bac7816ee9b1139d0e0d30e99fc06da4fb742e430c237d9be0e6261bcf5d8f3412f1c20a34e2766c5acc86176b4731f20adc9554de9949bd5622a5d SHA512 331614554bb7ba49b8b63b8612642426fb458aa84de78bb9958be85d03e43d662fc094ecd2472a6f06c6b4f0368ec0542083b04c25f7d8b6aabb432cd2b32367
DIST repoman-2.3.14.tar.bz2 86586 BLAKE2B 71ff01bc19817eedb80ff6b3dcd801bb48c49394503a88f2243fc04d56851836a079b6484ec72f794e28bbf9c74b8a99fbae6992ea2d2b5cee0d99fbe366d812 SHA512 1abbb139a63070ad2bf772ee2d0bd6e379f1cb6d32f1fed2f120325a856c2f919b8b26d2a27722eb64057c5f05a035c516ffcf2c6e7a878fdfcca978a622cb02
+DIST repoman-2.3.15.tar.bz2 86707 BLAKE2B 4c890fa311426d523c34fcaaf4e473fbaba6e3247cb55464709bf8547898df89420b4231a10181c06aafdeaa7ab6fffc02f8191f573487541dfd392945864b28 SHA512 d3f8d5d9b743d8fcd9e1a856a4c371747e235620105ed47f9c8b5933fbdcea7e8d556fc89e517834141bc575f15851cd833a56121bfdd55a1d81b3f86f859b74
diff --git a/app-portage/repoman/repoman-2.3.15.ebuild b/app-portage/repoman/repoman-2.3.15.ebuild
new file mode 100644
index 000000000000..f4313d582c61
--- /dev/null
+++ b/app-portage/repoman/repoman-2.3.15.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.3.43[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
+}