summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-01-10 11:25:44 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-01-10 11:26:00 +0300
commitf6f63bfc441de8807e7255f3381ec2845e1c723d (patch)
treef389953c553a29fe7ca1e010042de1de51766eb7 /app-portage
parentdev-ruby/mime-types: add ruby26 (diff)
downloadgentoo-f6f63bfc441de8807e7255f3381ec2845e1c723d.tar.gz
gentoo-f6f63bfc441de8807e7255f3381ec2845e1c723d.tar.bz2
gentoo-f6f63bfc441de8807e7255f3381ec2845e1c723d.zip
app-portage/eix: Drop old
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.33.2.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 9058448e894e..ec985a93691d 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,3 +1,2 @@
-DIST eix-0.33.2.tar.xz 614192 BLAKE2B dcbbdb9b9ccf6f780d89c791c34cc588700720b7f015fb0db7ea86dd78a383892266b0e96c49282fdea58e78293c69e8acc153cea631443c35d3ee29dd4c016f SHA512 28ca4cc57e5c7ef81feb37fa90d598e681e192c442c7446c93a442908d2a9744340f7a93c71135ec3083fb85c48a65638c8929b6e1e632464132f4320225d637
DIST eix-0.33.5.tar.xz 626628 BLAKE2B 2bb102279084f6bb6871bb4bbe55100708866337501c6043508ee13bdb92064c3a4a41d067b9d4c03af1a5ffbece53d9c66cf89639adf0c555a9511cae3d702f SHA512 7a71a411d4428ee491b9aee0f414e038a08f2195db58466db9b96f0d80edca7eaa153e63534c832c71e1b488e21fbd869a96bd10a21e06a93ce7eba1f808b684
DIST eix-0.33.6.tar.xz 625512 BLAKE2B 3f27e3cfa00dc4979bbebbd3b31dfa29e7dcd527fdf7b3ca3fdc6a4ce45a64d7f07fe20ea4a526533aa506c2d9e7fcbbf7b5e83ad6a2d4bbacd1ce75b6cde4ae SHA512 3f04f06533d4e7a0acd5b6e85d1194c8f9b013595ebe75c3dda06cce42e7721a57393aed17e9dd6437780b48378691d84b6e595999ce4321ad114b239313c7cf
diff --git a/app-portage/eix/eix-0.33.2.ebuild b/app-portage/eix/eix-0.33.2.ebuild
deleted file mode 100644
index 35f1e69f4cdb..000000000000
--- a/app-portage/eix/eix-0.33.2.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools bash-completion-r1 flag-o-matic tmpfiles
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc nls sqlite"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-2.0-r1
- >=app-shells/quoter-3.0_p2-r1"
-DEPEND="${BOTHDEPEND}
- app-arch/xz-utils
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache=${EROOT%/}/var/cache/${PN}
- if [[ -f ${old_cache} ]]; then
- rm "${old_cache}" || die
- fi
-}
-
-src_prepare() {
- default
- sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
-
- sed -e "/eixf_source=/s:push.sh:cat \"${EROOT}usr/share/push/push.sh\":" \
- -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EROOT}usr/share/quoter/quoter_pipe.sh\":" \
- -i src/eix-functions.sh.in || die
- sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EROOT}usr/share/eix/eix-functions\\\\\":" \
- -i src/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug paranoic-asserts)
- $(use_enable nls)
- $(use_with doc extra-doc)
- $(use_with sqlite)
-
- # default configuration
- $(use_with prefix always-accept-keywords)
- --with-dep-default
- --with-required-use-default
-
- # paths
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
-
- # build a single executable with symlinks
- --disable-separate-binaries
- --disable-separate-tools
-
- # used purely to control/disrespect *FLAGS
- --disable-debugging
- --disable-new_dialect
- --disable-optimization
- --disable-strong-optimization
- --disable-security
- --disable-nopie-security
- --disable-strong-security
- )
-
- # https://github.com/vaeth/eix/issues/35
- append-cxxflags -std=c++11
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-
- rm -r "${ED%/}"/usr/bin/eix-functions.sh || die
-
-}
-
-pkg_postinst() {
- tmpfiles_process eix.conf
-
- local obs=${EROOT%/}/var/cache/eix.previous
- if [[ -f ${obs} ]]; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
-}
-
-pkg_postrm() {
- if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
- rm -rf "${EROOT%/}/var/cache/${PN}" || die
- fi
-}