summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-29 10:06:58 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-29 10:16:48 +0200
commitf8039025292b2bbac64eedc22c6321ac442559fb (patch)
tree8adcb27bd178c24460113737f2be7d4af70f54d4 /app-portage
parentsys-auth/pambase: stable 20150213-r1 for sparc, bug #630356 (diff)
downloadgentoo-f8039025292b2bbac64eedc22c6321ac442559fb.tar.gz
gentoo-f8039025292b2bbac64eedc22c6321ac442559fb.tar.bz2
gentoo-f8039025292b2bbac64eedc22c6321ac442559fb.zip
app-portage/eix: Fix C++ standard to C++14 to fix code bugs
Closes: https://bugs.gentoo.org/649558 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/eix-0.33.2-r1.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/app-portage/eix/eix-0.33.2-r1.ebuild b/app-portage/eix/eix-0.33.2-r1.ebuild
new file mode 100644
index 000000000000..507d7acf722a
--- /dev/null
+++ b/app-portage/eix/eix-0.33.2-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT%/}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EROOT}usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EROOT}usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EROOT}usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ # https://github.com/vaeth/eix/issues/35
+ append-cxxflags -std=c++14
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED%/}"/usr/bin/eix-functions.sh || die
+
+ keepdir /var/cache/eix
+}
+
+pkg_postinst() {
+ if ! use prefix; then
+ # note: if this is done in src_install(), portage:portage
+ # ownership may be reset to root
+ tmpfiles_process eix.conf
+ fi
+
+ local obs=${EROOT%/}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT%/}/var/cache/${PN}" || die
+ fi
+}