summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-08-20 18:51:48 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-08-29 22:15:39 +0200
commit471ebe4be566d220cd63994b7eff89fe333868c1 (patch)
treeb77d454b30cb76f6db48f45d3647f40be50c03a7 /app-shells/mpv-bash-completion
parentmedia-video/vlc: Drop old (diff)
downloadgentoo-471ebe4be566d220cd63994b7eff89fe333868c1.tar.gz
gentoo-471ebe4be566d220cd63994b7eff89fe333868c1.tar.bz2
gentoo-471ebe4be566d220cd63994b7eff89fe333868c1.zip
app-shells/mpv-bash-completion: verbump to 3.3.15.
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5488
Diffstat (limited to 'app-shells/mpv-bash-completion')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.15.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index 65b955225a45..8f15adfae759 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1,2 +1,3 @@
DIST mpv-bash-completion-3.3.12.tar.gz 19310 SHA256 9291ef730af6f69cc0efc82e88d170d43d79266a1500461b08719130507870ef SHA512 f019e9a66072333b40213437f07097cacb9f01a1f322fded763e695ef5ef4656016ca07fcb402d406fd99785026dba1fc7292a2c04a14ac18a24557bb8ab2cd1 WHIRLPOOL 96db10c112767d8c8e648a989f416cb02123018e8406842ee27bfc603f5f6ca9ee6360f6aa46a19e14a194f44d510eb971219b10bb598785720c3a6f23047f6c
DIST mpv-bash-completion-3.3.13.tar.gz 19726 SHA256 65172975bfca59f9921afd9788c1e1532c734c068a6af21517eeec63b9a1ea34 SHA512 0f9301447c4f1d9443106e01c602a17f8d3ea62eacf63be807157c7b39a08d54c3cacb3a103fc8f77bc88dd71df433fe7bcb6c09bd3b9aeaa685c407c64cc3c7 WHIRLPOOL 3a1696dcf3cce68186e3fbee5f90982daaadf7fd238d022722b3e7d363a17551e066b953e08e40aac762d587d4cb839f3c704ac379572b62ad29ff5acba89779
+DIST mpv-bash-completion-3.3.15.tar.gz 19830 SHA256 1c3f4a6b95de7b573db3480dc79f7359207f7c95d31ac7368f6f5c84e9176ed8 SHA512 d4e263bb7c21f80b962bac9f1b01c594d5038d7a7095af0e7702dc5688fd69a9de1b5d8976f24d7a652a8fba4ceaf3ea2a81c771e7ea704807aeac0c526a09f6 WHIRLPOOL 740dc9f3e43031cba115b8c23bd7ac8d000f10f0a6e7a89144437c39b085d20dc09b47d540772afe7b2743cd444d71cda6231c795602fe9d262e8a699a4cdb77
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.15.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.15.ebuild
new file mode 100644
index 000000000000..cc0b326cb44d
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.25.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}