summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-11-19 10:07:16 +0300
committerMichael Palimaka <kensington@gentoo.org>2017-11-19 18:57:54 +1100
commitdd513ff9bed6697fedf59b553cf8aa9ee90487ba (patch)
treedd1ff0d48accbda1511a30e2fe809483367379d3 /app-shells/mpv-bash-completion
parentkde-misc/latte-dock: version bump 0.7.2 (diff)
downloadgentoo-dd513ff9bed6697fedf59b553cf8aa9ee90487ba.tar.gz
gentoo-dd513ff9bed6697fedf59b553cf8aa9ee90487ba.tar.bz2
gentoo-dd513ff9bed6697fedf59b553cf8aa9ee90487ba.zip
app-shells/mpv-bash-completion: verbump to 3.3.16
Closes: https://github.com/gentoo/gentoo/pull/6231 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-shells/mpv-bash-completion')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index 1b01f923653b..cda4cc319c4b 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1,2 +1,3 @@
DIST mpv-bash-completion-3.3.12.tar.gz 19310 SHA256 9291ef730af6f69cc0efc82e88d170d43d79266a1500461b08719130507870ef SHA512 f019e9a66072333b40213437f07097cacb9f01a1f322fded763e695ef5ef4656016ca07fcb402d406fd99785026dba1fc7292a2c04a14ac18a24557bb8ab2cd1 WHIRLPOOL 96db10c112767d8c8e648a989f416cb02123018e8406842ee27bfc603f5f6ca9ee6360f6aa46a19e14a194f44d510eb971219b10bb598785720c3a6f23047f6c
DIST mpv-bash-completion-3.3.15.tar.gz 19830 SHA256 1c3f4a6b95de7b573db3480dc79f7359207f7c95d31ac7368f6f5c84e9176ed8 SHA512 d4e263bb7c21f80b962bac9f1b01c594d5038d7a7095af0e7702dc5688fd69a9de1b5d8976f24d7a652a8fba4ceaf3ea2a81c771e7ea704807aeac0c526a09f6 WHIRLPOOL 740dc9f3e43031cba115b8c23bd7ac8d000f10f0a6e7a89144437c39b085d20dc09b47d540772afe7b2743cd444d71cda6231c795602fe9d262e8a699a4cdb77
+DIST mpv-bash-completion-3.3.16.tar.gz 20125 SHA256 9b8fe4ab052ce514520005f04857cf1ce401dae6422467799d1da581dc4ee9ae SHA512 d962cc911d571b0345ddee22ecae6faef307f2da44642d6db5223fb0e51d2b2087b038e1964cf8f1ed683bb95a3268a8ffc1fff2759561100b23921406a0e31f WHIRLPOOL 624ca95528effe931a73adc98fe5266041e465933282ab51e95c6193735e538f7ded7cb07f8191e893a9ddf6d2b593401f5dbb5f1a22bdc71cff14666603d6da
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild
new file mode 100644
index 000000000000..cc0b326cb44d
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.25.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}