summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-08 19:46:34 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-08 19:49:43 +0100
commit31cee08cd3e82e065e125b107409d7b242d340f6 (patch)
tree3610c3ed14a3a7569d1fafb071922816713b135c /app-shells
parentdev-lang/rust: simplify unpack (diff)
downloadgentoo-31cee08cd3e82e065e125b107409d7b242d340f6.tar.gz
gentoo-31cee08cd3e82e065e125b107409d7b242d340f6.tar.bz2
gentoo-31cee08cd3e82e065e125b107409d7b242d340f6.zip
app-shells/fish: Bump to version 2.4.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-2.4.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index 96d6841a74f8..96b77833907c 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -3,3 +3,4 @@ DIST fish-2.1.2.tar.gz 1730198 SHA256 c6c20d5ca3a2a0168461de8abfe85f9e6b25513269
DIST fish-2.2.0.tar.gz 2213037 SHA256 a76339fd14ce2ec229283c53e805faac48c3e99d9e3ede9d82c0554acfc7b77a SHA512 210047f56b105a3d372f03d3a2de41661ed18001e3c8fa053ae4aa43089118d4467837ea022bc44f9877ecc3d0563b365f97920c002faccebaa663c4f079e9e0 WHIRLPOOL 8b25e437e0c942255b5f39686008fb37ec45cea52e04b2d61facf1fdcd59510138dace506eadb17eb0074d175d3c1226d6e52d437e325ed5a90e22e696918d9d
DIST fish-2.3.0.tar.gz 4537458 SHA256 912bac47552b1aa0d483a39ade330356632586a8f726c0e805b46d45cfad54e5 SHA512 acfeb8daad34250c626172428573d5baf86c43d37379fb29da296973931cb5e0b8d7cb5d2ed64eb6e3b984a3a65fc800dd8f78dce7d5e4719bc5dc143be27e8a WHIRLPOOL 1a9023540307fba2bf594ff785ae2f825e62addba920f312aeae6afaaf394cbb4a90f7fc205496ed49d7efb0cb460acd737e61af262bcbee3013d148e70ca9ed
DIST fish-2.3.1.tar.gz 4502836 SHA256 328acad35d131c94118c1e187ff3689300ba757c4469c8cc1eaa994789b98664 SHA512 dd0fa77f218cc84943c577ff8abafcde92fa953797757a62db317d87c2af82de6493810ce91012e20d46be9a52bffda9a40526328714ba1e4e389e5f2aa3fea5 WHIRLPOOL 823ad3b05aada036a96aff71693655d1683d1862a1f994163c0833af29230211e7b28bc77eb33d56baa2be87ec93532464ed818d7f167ef562df54301b23bb44
+DIST fish-2.4.0.tar.gz 3455874 SHA256 06bbb2323360439c4044da762d114ec1aa1aba265cec71c0543e6a0095c9efc5 SHA512 b27a2291c284fda7a12b3cd5dcba8dfcbf2738f50de40d9aac1500afa3bd98be04b4f67d7e6d3bb2f808c11a8c2dd6b1b5cc2dfe3e8e0e7d1bc88f8d8994d57b WHIRLPOOL abb9c31237a33553b25920fe3284f4ca90941aed2b8f1ec4b69fdb4231f7b2585f0292bc647ffe3acf88f6b01ac61931f615fa9a56ede35a8182e3a69aa11861
diff --git a/app-shells/fish/fish-2.4.0.ebuild b/app-shells/fish/fish-2.4.0.ebuild
new file mode 100644
index 000000000000..154c96518a59
--- /dev/null
+++ b/app-shells/fish/fish-2.4.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses:0=
+ sys-devel/bc
+ sys-devel/gettext
+ X? ( x11-misc/xsel )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ emake test
+ else
+ ewarn "The test suite only works when the package is already installed"
+ fi
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
+ elog "browser of your choice to get acces to ${PN}'s help system:"
+ elog " BROWSER=\"/usr/bin/firefox\""
+ elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
+ elog "Have fun!"
+}