summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-18 18:46:28 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-18 18:52:00 +0100
commita219ed08ce84f92bd794e7dc81acfacd454966f7 (patch)
treec65a68658254d1ca5bfcd2ff1b134844e5a81a31 /app-shells
parentnet-misc/wireguard: bump (diff)
downloadgentoo-a219ed08ce84f92bd794e7dc81acfacd454966f7.tar.gz
gentoo-a219ed08ce84f92bd794e7dc81acfacd454966f7.tar.bz2
gentoo-a219ed08ce84f92bd794e7dc81acfacd454966f7.zip
app-shells/hstr: EAPI 6 bump. Convert ebuild away from autotools-utils.eclass and to {autotools,multilib-minimal}.eclass.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/hstr/hstr-1.21-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-1.21-r1.ebuild b/app-shells/hstr/hstr-1.21-r1.ebuild
new file mode 100644
index 000000000000..56d90876cb9f
--- /dev/null
+++ b/app-shells/hstr/hstr-1.21-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}