summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-01 15:00:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-01 15:00:30 -0500
commitf216ce5fd9fdcaefe20b7f72eca0ad8fa32e19d2 (patch)
tree4d4fc886957977c0dc632973abc73bba200bb31b /app-shells
parentdev-python/pytest-expect: stable 1.1.0-r1 for sparc, bug #726552 (diff)
downloadgentoo-f216ce5fd9fdcaefe20b7f72eca0ad8fa32e19d2.tar.gz
gentoo-f216ce5fd9fdcaefe20b7f72eca0ad8fa32e19d2.tar.bz2
gentoo-f216ce5fd9fdcaefe20b7f72eca0ad8fa32e19d2.zip
app-shells/powerline: fix respecting ldflags
Closes: https://bugs.gentoo.org/726700 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/powerline/files/2.7-ldflags.patch15
-rw-r--r--app-shells/powerline/powerline-2.7-r1.ebuild (renamed from app-shells/powerline/powerline-2.7.ebuild)4
2 files changed, 19 insertions, 0 deletions
diff --git a/app-shells/powerline/files/2.7-ldflags.patch b/app-shells/powerline/files/2.7-ldflags.patch
new file mode 100644
index 000000000000..077c28af2a07
--- /dev/null
+++ b/app-shells/powerline/files/2.7-ldflags.patch
@@ -0,0 +1,15 @@
+diff -Naur powerline-status-2.7/setup.py powerline-status-2.7.new/setup.py
+--- powerline-status-2.7/setup.py 2018-08-12 14:41:44.000000000 -0500
++++ powerline-status-2.7.new/setup.py 2020-06-01 14:56:25.977968288 -0500
+@@ -30,9 +30,10 @@
+ from distutils.ccompiler import new_compiler
+ compiler = new_compiler().compiler
+ cflags = os.environ.get('CFLAGS', str('-O3'))
++ ldflags = os.environ.get('LDFLAGS', str(''))
+ # A normal split would do a split on each space which might be incorrect. The
+ # shlex will not split if a space occurs in an arguments value.
+- subprocess.check_call(compiler + shlex.split(cflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
++ subprocess.check_call(compiler + shlex.split(cflags) + shlex.split(ldflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
+
+ try:
+ compile_client()
diff --git a/app-shells/powerline/powerline-2.7.ebuild b/app-shells/powerline/powerline-2.7-r1.ebuild
index 946e4c10304a..623ac6d9568c 100644
--- a/app-shells/powerline/powerline-2.7.ebuild
+++ b/app-shells/powerline/powerline-2.7-r1.ebuild
@@ -25,3 +25,7 @@ RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/2.7-ldflags.patch
+)