summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/agrep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/agrep')
-rw-r--r--app-text/agrep/Manifest1
-rw-r--r--app-text/agrep/agrep-2.04-r1.ebuild34
-rw-r--r--app-text/agrep/agrep-2.04.ebuild33
-rw-r--r--app-text/agrep/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/agrep/Manifest b/app-text/agrep/Manifest
new file mode 100644
index 000000000000..ccfab3e105e7
--- /dev/null
+++ b/app-text/agrep/Manifest
@@ -0,0 +1 @@
+DIST agrep-2.04.tar.Z 62351 SHA256 31275a2fee28fb8966e1978d26fe8113b61ce49b39e68ddf4cad3964db72d5f8 SHA512 4524250c2c0b309243fd245efb04fa8d867f45a92b0d977b29d2ff8ec99586c16c35b8a78cdd5aeb4c529fe0270c8b1220d6ddf52d947e6181a5f04bdbed5aee WHIRLPOOL a77870cb9b08512a847acf203d6b5ccad343a9b0bff107d8d768a9d5545c01ecccf860b0e35a9be82a46bbfc5718ba963145016dc8039ab3c157ba0a824316b0
diff --git a/app-text/agrep/agrep-2.04-r1.ebuild b/app-text/agrep/agrep-2.04-r1.ebuild
new file mode 100644
index 000000000000..dee0d55744c2
--- /dev/null
+++ b/app-text/agrep/agrep-2.04-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="agrep is a tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 ~sparc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !dev-libs/tre
+ !app-misc/glimpse"
+
+src_compile() {
+ # Remove first occurace of CFLAGS so we grab the user CFLAGS
+ sed -i -e 's/^CFLAGS.*//' \
+ -e "s:\$(CFLAGS):& \$(LDFLAGS) :" Makefile || die
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin agrep || die
+ doman agrep.1 || die
+ dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
+ contribution.list || die
+}
diff --git a/app-text/agrep/agrep-2.04.ebuild b/app-text/agrep/agrep-2.04.ebuild
new file mode 100644
index 000000000000..f7bc2f671725
--- /dev/null
+++ b/app-text/agrep/agrep-2.04.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="agrep is a tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !dev-libs/tre
+ !app-misc/glimpse"
+
+src_compile() {
+ # Remove first occurace of CFLAGS so we grab the user CFLAGS
+ sed -i -e 's/^CFLAGS.*//' Makefile || die
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin agrep || die
+ doman agrep.1 || die
+ dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
+ contribution.list || die
+}
diff --git a/app-text/agrep/metadata.xml b/app-text/agrep/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-text/agrep/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>