summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2015-11-09 16:59:23 +0100
committerMarc Joliet <marcec@gmx.de>2015-11-20 16:08:35 +0100
commit168218b3a889f0357c7bebd3c42286bfa482f04d (patch)
tree59ca9b5beb945a9ee24a472747c4c3ac43d1cf01 /app-text/asciidoc
parentdev-python/numba: bump to 0.22.1. (diff)
downloadgentoo-168218b3a889f0357c7bebd3c42286bfa482f04d.tar.gz
gentoo-168218b3a889f0357c7bebd3c42286bfa482f04d.tar.bz2
gentoo-168218b3a889f0357c7bebd3c42286bfa482f04d.zip
app-text/asciidoc: remove vim-syntax from IUSE
The vim-syntax USE flag is useless now, for the following reasons: - The actions it controls have no effect, since the Makefile.in doesn't do anything vim-related anymore, as mentioned in the CHANGELOG. - Vim comes with its own syntax file since version 7.4, which is maintained (by AsciiDoc upstream, according to its header) and was last updated in 2014, whereas the upstream syntax file has not been changed since 2013. Gentoo-bug: 530808 Signed-off-by: Marc Joliet <marcec@gmx.de>
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/asciidoc-8.6.9-r2.ebuild13
-rw-r--r--app-text/asciidoc/asciidoc-9999.ebuild13
2 files changed, 2 insertions, 24 deletions
diff --git a/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild b/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
index e329c8e742d5..94f5ba0f9c90 100644
--- a/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
+++ b/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~spa
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples graphviz highlight test vim-syntax"
+IUSE="examples graphviz highlight test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -44,15 +44,6 @@ REQUISITES for a list of runtime dependencies.
"
src_prepare() {
- if ! use vim-syntax; then
- sed -i -e '/^install/s/install-vim//' Makefile.in || die
- else
- sed -i\
- -e "/^vimdir/s:@sysconfdir@/vim:${EPREFIX}/usr/share/vim/vimfiles:" \
- -e 's:/etc/vim::' \
- Makefile.in || die
- fi
-
# Only needed for prefix - harmless (does nothing) otherwise
sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
"${S}/asciidoc.py" || die
@@ -63,8 +54,6 @@ src_configure() {
}
src_install() {
- use vim-syntax && dodir /usr/share/vim/vimfiles
-
emake DESTDIR="${D}" install
python_fix_shebang "${ED}"/usr/bin/*.py
diff --git a/app-text/asciidoc/asciidoc-9999.ebuild b/app-text/asciidoc/asciidoc-9999.ebuild
index 0a4f1a949fe4..81bb1da1eed0 100644
--- a/app-text/asciidoc/asciidoc-9999.ebuild
+++ b/app-text/asciidoc/asciidoc-9999.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples graphviz highlight test vim-syntax"
+IUSE="examples graphviz highlight test"
REQUIRED_USE="highlight? ( ${PYTHON_REQUIRED_USE} )"
@@ -58,15 +58,6 @@ if [ "$PV" == "9999" ]; then
fi
src_prepare() {
- if ! use vim-syntax; then
- sed -i -e '/^install/s/install-vim//' Makefile.in || die
- else
- sed -i\
- -e "/^vimdir/s:@sysconfdir@/vim:${EPREFIX}/usr/share/vim/vimfiles:" \
- -e 's:/etc/vim::' \
- Makefile.in || die
- fi
-
# Only needed for prefix - harmless (does nothing) otherwise
sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
"${S}/asciidoc.py" || die
@@ -88,8 +79,6 @@ src_compile() {
}
src_install() {
- use vim-syntax && dodir /usr/share/vim/vimfiles
-
emake DESTDIR="${D}" install
python_fix_shebang "${ED}"/usr/bin/*.py