summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/djvu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/djvu')
-rw-r--r--app-text/djvu/Manifest2
-rw-r--r--app-text/djvu/djvu-3.5.25.3.ebuild73
-rw-r--r--app-text/djvu/djvu-3.5.27.ebuild64
-rw-r--r--app-text/djvu/files/djvu-3.5.24-gcc46.patch40
-rw-r--r--app-text/djvu/metadata.xml18
5 files changed, 197 insertions, 0 deletions
diff --git a/app-text/djvu/Manifest b/app-text/djvu/Manifest
new file mode 100644
index 000000000000..e8342e17f4c4
--- /dev/null
+++ b/app-text/djvu/Manifest
@@ -0,0 +1,2 @@
+DIST djvulibre-3.5.25.3.tar.gz 2543949 SHA256 898d7ed6dd2fa311a521baa95407a91b20a872d80c45e8245442d64f142cb1e0 SHA512 0e38f56d77915ee6707dd19a36a8ca9167608c39449a5c73de9cd784d712852c07c068b79a794e25f6d3ded0f927d083413dde197c9fc8f7b68c03cffe68035b WHIRLPOOL 43ce341be7dd6322f7bf05ed541e9eb6b8b923d95893bb8f8b78761ae452384e39c39e23723b4d0fc7fe8e95301dc414ac9c2d74a169a6ae12b86e5968f1edc3
+DIST djvulibre-3.5.27.tar.gz 3648522 SHA256 e69668252565603875fb88500cde02bf93d12d48a3884e472696c896e81f505f SHA512 62abcaa2fe7edab536477929ba38b882453dab1a06e119a3f838b38d5c61f5d8c252e4769e6534582b826e49bcfb490513179580fab9c3afa84aa92053ccebee WHIRLPOOL 7caff93eeaaaccb393c03013b62220cfc1b1a50e4d6da4a107ae0267fed1f5f9e6d3ad2b61845be5192b67917ec064a2c21c0f4ad567d4b0d6f56168ae4593bc
diff --git a/app-text/djvu/djvu-3.5.25.3.ebuild b/app-text/djvu/djvu-3.5.25.3.ebuild
new file mode 100644
index 000000000000..e4efe101312a
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.25.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils fdo-mime flag-o-matic
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities"
+HOMEPAGE="http://djvu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug doc jpeg tiff xml"
+
+RDEPEND="jpeg? ( virtual/jpeg:0 )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}
+ || ( gnome-base/librsvg media-gfx/inkscape )"
+
+S=${WORKDIR}/${MY_P%%.3}
+
+src_prepare() {
+ sed -i \
+ -e 's/AC_CXX_OPTIMIZE/OPTS=;AC_SUBST(OPTS)/' \
+ configure.ac || die #263688
+ rm aclocal.m4 config/{libtool.m4,ltmain.sh,install-sh,config.sub,config.guess,ltoptions.m4,ltversion.m4,lt~obsolete.m4}
+# epatch "${FILESDIR}/${PN}-3.5.24-gcc46.patch"
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
+
+ # We install all desktop files by hand.
+ econf \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ --disable-desktopfiles
+}
+
+DOCS=( NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+
+ use doc && dodoc -r doc
+
+ # Install desktop files.
+ cd desktopfiles
+ for i in {22,32,48,64}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
+ newins hi${i}-djvu.png image-vnd.djvu.png
+ done
+ insinto /usr/share/mime/packages
+ doins djvulibre-mime.xml
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ if ! has_version app-text/djview; then
+ elog "For djviewer or browser plugin, emerge app-text/djview."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/djvu/djvu-3.5.27.ebuild b/app-text/djvu/djvu-3.5.27.ebuild
new file mode 100644
index 000000000000..be1c6c35e06d
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.27.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime flag-o-matic
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities"
+HOMEPAGE="http://djvu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug doc jpeg tiff xml"
+
+RDEPEND="jpeg? ( virtual/jpeg:0 )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}
+ || ( gnome-base/librsvg media-gfx/inkscape )"
+
+S=${WORKDIR}/${MY_P%%.3}
+
+src_configure() {
+ use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
+
+ # We install all desktop files by hand.
+ econf \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ --disable-desktopfiles
+}
+
+DOCS=( NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+
+ use doc && dodoc -r doc
+
+ # Install desktop files.
+ cd desktopfiles
+ for i in {22,32,48,64}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
+ newins prebuilt-hi${i}-djvu.png image-vnd.djvu.png
+ done
+ insinto /usr/share/mime/packages
+ doins djvulibre-mime.xml
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ if ! has_version app-text/djview; then
+ elog "For djviewer or browser plugin, emerge app-text/djview."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/djvu/files/djvu-3.5.24-gcc46.patch b/app-text/djvu/files/djvu-3.5.24-gcc46.patch
new file mode 100644
index 000000000000..2d1d099bfbb9
--- /dev/null
+++ b/app-text/djvu/files/djvu-3.5.24-gcc46.patch
@@ -0,0 +1,40 @@
+http://bugs.gentoo.org/361057 for GSmartPointer.h change
+
+Then include stddef.h in the installed headers to fix building of reverse
+dependencies, such as app-text/zathura-djvu
+
+These are all in upstream GIT
+
+--- a/libdjvu/ddjvuapi.h
++++ b/libdjvu/ddjvuapi.h
+@@ -64,6 +64,7 @@
+ }
+ #endif
+
++#include <stddef.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+
+--- a/libdjvu/GSmartPointer.h
++++ b/libdjvu/GSmartPointer.h
+@@ -62,6 +62,8 @@
+ # pragma interface
+ #endif
+
++#include <cstddef>
++
+ /** @name GSmartPointer.h
+
+ Files #"GSmartPointer.h"# and #"GSmartPointer.cpp"# define a smart-pointer
+--- a/libdjvu/miniexp.h
++++ b/libdjvu/miniexp.h
+@@ -38,7 +38,8 @@
+ #ifndef MINILISPAPI
+ # define MINILISPAPI /**/
+ #endif
+-
++
++#include <stddef.h>
+
+ /* -------------------------------------------------- */
+ /* LISP EXPRESSIONS */
diff --git a/app-text/djvu/metadata.xml b/app-text/djvu/metadata.xml
new file mode 100644
index 000000000000..b485c3124aa0
--- /dev/null
+++ b/app-text/djvu/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <longdescription>
+DjVu is a web-centric format and software platform for distributing documents
+and images. DjVu can advantageously replace PDF, PS, TIFF, JPEG, and GIF for
+distributing scanned documents, digital documents, or high-resolution pictures.
+DjVu content downloads faster, displays and renders faster, looks nicer on a
+screen, and consume less client resources than competing formats. DjVu images
+display instantly and can be smoothly zoomed and panned with no lengthy
+re-rendering. DjVu is used by hundreds of academic, commercial, governmental,
+and non-commercial web sites around the world.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">djvu</remote-id>
+ </upstream>
+</pkgmetadata>