summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-29 15:02:50 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-29 15:02:50 +0200
commit16e38a842f1728d38f9dec7e26a32c172d3503fc (patch)
tree71f7520d2c866c97af471144178f0823eee18fac /app-text/gnome-doc-utils
parentgnome-base/gnome-keyring: Pull pinentry in PDEPEND (#570512) (diff)
downloadgentoo-16e38a842f1728d38f9dec7e26a32c172d3503fc.tar.gz
gentoo-16e38a842f1728d38f9dec7e26a32c172d3503fc.tar.bz2
gentoo-16e38a842f1728d38f9dec7e26a32c172d3503fc.zip
app-text/gnome-doc-utils: Parallel build fails (#574282)
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-text/gnome-doc-utils')
-rw-r--r--app-text/gnome-doc-utils/gnome-doc-utils-0.20.10-r1.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10-r1.ebuild b/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10-r1.ebuild
index 66c1556ff284..efd1d43334c0 100644
--- a/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10-r1.ebuild
+++ b/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-GCONF_DEBUG="no"
+EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit gnome2 multibuild python-r1
@@ -18,9 +17,8 @@ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-libs/libxml2-2.6.12[python,${PYTHON_USEDEP}]
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/libxml2-2.6.12:2[python,${PYTHON_USEDEP}]
>=dev-libs/libxslt-1.1.8
"
DEPEND="${RDEPEND}
@@ -38,7 +36,7 @@ DEPEND="${RDEPEND}
src_prepare() {
# Stop build from relying on installed package
- epatch "${FILESDIR}"/${P}-fix-out-of-tree-build.patch
+ eapply "${FILESDIR}"/${P}-fix-out-of-tree-build.patch
gnome2_src_prepare
@@ -57,7 +55,7 @@ src_configure() {
}
src_compile() {
- python_foreach_impl run_in_build_dir gnome2_src_compile
+ MAKEOPTS="${MAKEOPTS} -j1" python_foreach_impl run_in_build_dir gnome2_src_compile #574282
}
src_test() {
@@ -65,7 +63,6 @@ src_test() {
}
src_install() {
- dodoc AUTHORS ChangeLog NEWS README
python_foreach_impl run_in_build_dir gnome2_src_install
python_replicate_script "${ED}"/usr/bin/xml2po
}