summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-01-28 20:24:17 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-01-28 20:24:17 +0100
commitcede48d0706179327dbc7ffcb679b1772b4e6e43 (patch)
treed62bfa4b66fb05391f821da7b370db390d3cf813 /app-text/gspell
parentapp-text/enchant: bump to 2.2.3 (diff)
downloadgentoo-cede48d0706179327dbc7ffcb679b1772b4e6e43.tar.gz
gentoo-cede48d0706179327dbc7ffcb679b1772b4e6e43.tar.bz2
gentoo-cede48d0706179327dbc7ffcb679b1772b4e6e43.zip
app-text/gspell: bump to 1.8.1
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.8.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 09a1776eb8de..e517025f3b5d 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1 +1,2 @@
DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
+DIST gspell-1.8.1.tar.xz 419268 BLAKE2B f32c9c518c23f8f560d65eb6fb122703561cc09e385eefa99d0761e8aa5b5bf3a8cec3cab7071043134314262979de56d08ee2929973b7968016b123e53d8f16 SHA512 ae94f46c7bdcdeefa0279cd4ac3c50e53b63092016e298ef6b502c40c2574a2135c503ab322f5a3a7b8b4422fdec291a6ed0c937683a8c0f32d7ad474cc1569b
diff --git a/app-text/gspell/gspell-1.8.1.ebuild b/app-text/gspell/gspell-1.8.1.ebuild
new file mode 100644
index 000000000000..3226d1b01c67
--- /dev/null
+++ b/app-text/gspell/gspell-1.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-2.1.3
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}