summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/htmlinc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/htmlinc')
-rw-r--r--app-text/htmlinc/Manifest1
-rw-r--r--app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch129
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild38
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1.ebuild30
-rw-r--r--app-text/htmlinc/metadata.xml7
5 files changed, 205 insertions, 0 deletions
diff --git a/app-text/htmlinc/Manifest b/app-text/htmlinc/Manifest
new file mode 100644
index 000000000000..d0978fe820c6
--- /dev/null
+++ b/app-text/htmlinc/Manifest
@@ -0,0 +1 @@
+DIST htmlinc.tar.gz 17042 SHA256 e3323552591d27ff8160e7c0e440193734637d4acaa53cf756cc9f04b4ae61a7 SHA512 2bdb7a5df4a8152d9a23f7b740995bd565e92998ef199cfb7d08b1f5e8ae4390c5179f78da71dfa4b7ce18a2a0bfe6002d465b0fa8d860a25afdec5eb4f3ee4c WHIRLPOOL 8aa66b48ebc0320cc45b813a4b99240d0aa60e62c43a5cf0fb56135fbcbcd33f3b7c29522face7974bc0ef2622e7d8bb2e0afdf1d7203c77365fcbacb39c777b
diff --git a/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
new file mode 100644
index 000000000000..eb92c07ff51b
--- /dev/null
+++ b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
@@ -0,0 +1,129 @@
+diff -u htmlinc/bytevector.cc htmlinc-1/bytevector.cc
+--- htmlinc/bytevector.cc 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/bytevector.cc 2002-09-11 13:55:25.000000000 +0200
+@@ -119,7 +119,7 @@
+ }
+
+ bool Bytevector::freadln(int file,char seperator){
+- vector<Bytevector*> v;
++ std::vector<Bytevector*> v;
+ Bytevector *b;
+ int index=0;
+ int status;
+@@ -152,7 +152,7 @@
+
+
+ void Bytevector::freadeof(int file){
+- vector<Bytevector*> v;
++ std::vector<Bytevector*> v;
+ Bytevector *b;
+ int index=0;
+ int status;
+diff -u htmlinc/bytevector.h htmlinc-1/bytevector.h
+--- htmlinc/bytevector.h 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/bytevector.h 2002-09-11 13:54:50.000000000 +0200
+@@ -54,7 +54,7 @@
+
+
+
+-class VectorIndexList : public vector<int> {
++class VectorIndexList : public std::vector<int> {
+ };
+
+
+diff -u htmlinc/stringlist.cc htmlinc-1/stringlist.cc
+--- htmlinc/stringlist.cc 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/stringlist.cc 2002-09-11 13:57:47.000000000 +0200
+@@ -283,7 +283,7 @@
+ for (Stringlist::iterator i=begin(); i!=end(); i++){
+ delete *i;
+ }
+- vector<Bytevector *>::clear();
++ std::vector<Bytevector *>::clear();
+ }
+
+
+@@ -373,7 +373,7 @@
+
+ void Stringlist::insert(Bytevector *b, int pos){
+ iterator i=begin()+pos;
+- vector<Bytevector *>::insert(i,b);
++ std::vector<Bytevector *>::insert(i,b);
+ }
+
+ void Stringlist::insert(Bytevector &b, int pos){
+@@ -417,7 +417,7 @@
+
+
+ Bytevector& Stringlist::operator[](int i){
+- return *(vector<Bytevector *>::operator[](i));
++ return *(std::vector<Bytevector *>::operator[](i));
+ }
+
+
+diff -u htmlinc/stringlist.h htmlinc-1/stringlist.h
+--- htmlinc/stringlist.h 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/stringlist.h 2002-09-11 13:56:32.000000000 +0200
+@@ -57,12 +57,12 @@
+ }
+ };
+
+-class MatrixIndexList: public vector<MatrixIndex> {
++class MatrixIndexList: public std::vector<MatrixIndex> {
+ };
+
+
+
+-class Stringlist : public vector<Bytevector*> {
++class Stringlist : public std::vector<Bytevector*> {
+ private:
+ Stringlist::iterator getID(Bytevector id);
+
+diff -Naur htmlinc-old/help.h htmlinc/help.h
+--- htmlinc/help.h 2000-08-08 09:04:28.000000000 -0400
++++ htmlinc-1/help.h 2004-03-01 19:43:43.770233421 -0500
+@@ -4,25 +4,25 @@
+
+ char * helpV[]=
+ {
+-{"HTML INCLUDE SYSTEM Version 1.0 beta1 - Compatible to Phase 5"},
+-{"Copyright (C) 2000 , Ulli Meybohm, www.meybohm.de (GNU General Public License)"},
+-{""},
+-{"Start: "},
+-{" htmlinc <include_dir> <htmlfile_1> <htmlfile_2> ... <htmlfile_n>"},
+-{""},
+-{"Options:"},
+-{" <include_dir> = Directory of the Includefiles"},
+-{" <htmlfile_i> = HTML-Files in which the includes should be updated"},
+-{""},
+-{"Examples:"},
+-{" 1: htmlinc ~/www/inc/ *.html"},
+-{""},
+-{" 2: cd ~/www"},
+-{" htmlinc inc/ `find * | grep \"\\\\.\"html` (recursive)"},
+-{" "},
+-{""},
+-{"Report bugs to ulli@meybohm.de."},
+-{""}
++"HTML INCLUDE SYSTEM Version 1.0 beta1 - Compatible to Phase 5",
++"Copyright (C) 2000 , Ulli Meybohm, www.meybohm.de (GNU General Public License)",
++"",
++"Start: ",
++" htmlinc <include_dir> <htmlfile_1> <htmlfile_2> ... <htmlfile_n>",
++"",
++"Options:",
++" <include_dir> = Directory of the Includefiles",
++" <htmlfile_i> = HTML-Files in which the includes should be updated",
++"",
++"Examples:",
++" 1: htmlinc ~/www/inc/ *.html",
++"",
++" 2: cd ~/www",
++" htmlinc inc/ `find * | grep \"\\\\.\"html` (recursive)",
++" ",
++"",
++"Report bugs to ulli@meybohm.de.",
++""
+ };
+
+ int helpC=18;
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
new file mode 100644
index 000000000000..6fba64918e0c
--- /dev/null
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="HTML Include System by Ulli Meybohm"
+HOMEPAGE="http://www.meybohm.de/"
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/htmlinc
+
+src_prepare() {
+ epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ # This is C++ not C source
+ emake \
+ CC=$(tc-getCXX) \
+ CFLAGS="${CXXFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin htmlinc
+ dodoc README
+}
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
new file mode 100644
index 000000000000..59f6850d7686
--- /dev/null
+++ b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="HTML Include System by Ulli Meybohm"
+HOMEPAGE="http://www.meybohm.de/"
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+S=${WORKDIR}/htmlinc
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/htmlinc-gcc3-gentoo.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CXXFLAGS} -Wall" || die
+}
+
+src_install() {
+ dobin htmlinc
+}
diff --git a/app-text/htmlinc/metadata.xml b/app-text/htmlinc/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-text/htmlinc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>