summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-01 15:17:51 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-01 15:18:26 +0200
commit609ec6733e7c10b6d2a1afee00fa6999bf89ce91 (patch)
treed7a2aac7548f0b3177ca281df176d3681bc3c472 /app-text/krop/krop-0.4.11.ebuild
parentmail-client/mutt: version bump to 1.7.0 (diff)
downloadgentoo-609ec6733e7c10b6d2a1afee00fa6999bf89ce91.tar.gz
gentoo-609ec6733e7c10b6d2a1afee00fa6999bf89ce91.tar.bz2
gentoo-609ec6733e7c10b6d2a1afee00fa6999bf89ce91.zip
app-text/krop: Version bump to 0.4.11, add python3 support
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/krop/krop-0.4.11.ebuild')
-rw-r--r--app-text/krop/krop-0.4.11.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/krop/krop-0.4.11.ebuild b/app-text/krop/krop-0.4.11.ebuild
new file mode 100644
index 000000000000..04d593f2e48c
--- /dev/null
+++ b/app-text/krop/krop-0.4.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}