summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-06-05 12:06:49 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-07-03 22:27:41 +0200
commit9dbaba3637a5b6395a2ab18c4687b88d2802c286 (patch)
tree185e2be2f4edfae2ae48b397b98f31b36dbc1f85 /app-text/libetonyek
parentapp-text/libodfgen: Drop old (diff)
downloadgentoo-9dbaba3637a5b6395a2ab18c4687b88d2802c286.tar.gz
gentoo-9dbaba3637a5b6395a2ab18c4687b88d2802c286.tar.bz2
gentoo-9dbaba3637a5b6395a2ab18c4687b88d2802c286.zip
app-text/libetonyek: Drop old
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text/libetonyek')
-rw-r--r--app-text/libetonyek/Manifest1
-rw-r--r--app-text/libetonyek/files/libetonyek-0.0.3-comma.patch11
-rw-r--r--app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch56
-rw-r--r--app-text/libetonyek/libetonyek-0.0.3.ebuild59
4 files changed, 0 insertions, 127 deletions
diff --git a/app-text/libetonyek/Manifest b/app-text/libetonyek/Manifest
index c70916d26ab0..c057d31a5169 100644
--- a/app-text/libetonyek/Manifest
+++ b/app-text/libetonyek/Manifest
@@ -1,3 +1,2 @@
-DIST libetonyek-0.0.3.tar.xz 341276 SHA256 b5b96cd0857fc9a740d6ec737d613d95e9524103b9ab5a15bb6e645621d943e6 SHA512 9d60170e4404582e29bc3f04c4389f37fa6d1aedb2bf5f90fbc47230a02f184237cd3f49f8f578ccf92e2b28a84dd438a63f8e0c219697e15df3d47c86954a55 WHIRLPOOL 2a1334edd7843b0a8c05f04a9613fc7a580c93385f729d397224004ea07a417c6601e4295558b610a0a0458cf2d9ccd4b8d346d74d28caa490f61e59987471f1
DIST libetonyek-0.1.3.tar.xz 372884 SHA256 fe12276a62bd5f5ca4f5bfbd4938a74d097084e1f9fe173e521f63203f56f055 SHA512 912cb94e6cd63a162a8831368f953c4e6fb14b582a13a7ce93c0bcbb63b688fcbe4733dbb883d6a9faee2011ca5e888d00adda075c2a58d00858770ed68d6844 WHIRLPOOL 5fe864e37f6611c8cda92243a13e08e38ce1fd6f9544ddee7d3392fa9bfe573cd9af6ddd0ff03c7a0cee19b63c46b96398d985eaeb7367cd06aac8796d3655b8
DIST libetonyek-0.1.6.tar.xz 1243364 SHA256 df54271492070fbcc6aad9f81ca89658b25dd106cc4ab6b04b067b7a43dcc078 SHA512 10ae0403d98f33b27be4c3c905dec3df48cc01ce438f8760298edeadb76dd74da997edbd7dc03635fbc168b318bfe6e130f2306f495dfbf4135dd6dfcccabb4e WHIRLPOOL 932704f1d8bb1269e6be8e3fd7bd64af01ba0f098272befc747da9a4bd225bb201542bebf31d6e6338e613835fca4d7c6e2c1454df4ed764af30459393b6d73b
diff --git a/app-text/libetonyek/files/libetonyek-0.0.3-comma.patch b/app-text/libetonyek/files/libetonyek-0.0.3-comma.patch
deleted file mode 100644
index 1504acc4c115..000000000000
--- a/app-text/libetonyek/files/libetonyek-0.0.3-comma.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libetonyek-0.0.3/src/lib/KEYEnum.h 2013-12-06 09:40:36.000000000 +0100
-+++ libetonyek-0.0.3/src/lib/KEYEnum.h 2013-12-15 06:21:26.372083749 +0100
-@@ -33,7 +33,7 @@
- KEY_CAPITALIZATION_NONE,
- KEY_CAPITALIZATION_ALL_CAPS,
- KEY_CAPITALIZATION_SMALL_CAPS,
-- KEY_CAPITALIZATION_TITLE,
-+ KEY_CAPITALIZATION_TITLE
- };
-
- }
diff --git a/app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch b/app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch
deleted file mode 100644
index 19a5aead224d..000000000000
--- a/app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- libetonyek-0.0.3/src/lib/KEY2ParserUtils.cpp 2013-12-01 21:44:51.000000000 +0100
-+++ libetonyek-0.0.3/src/lib/KEY2ParserUtils.cpp 2013-12-15 06:53:07.474721349 +0100
-@@ -125,7 +125,7 @@
- return KEYSize(size.second, size.first);
- }
-
--bool KEY2ParserUtils::bool_cast(const char *const value)
-+bool KEY2ParserUtils::bool_cast(const char *value)
- {
- KEY2Tokenizer tok;
- switch (tok(value))
-@@ -142,6 +142,16 @@
- return false;
- }
-
-+double KEY2ParserUtils::double_cast(const char *value)
-+{
-+ return lexical_cast<double, const char *>(value);
-+}
-+
-+int KEY2ParserUtils::int_cast(const char *value)
-+{
-+ return lexical_cast<int, const char *>(value);
-+}
-+
- double KEY2ParserUtils::deg2rad(double value)
- {
- // normalize range
---- libetonyek-0.0.3/src/lib/KEY2ParserUtils.h 2013-10-30 22:04:38.000000000 +0100
-+++ libetonyek-0.0.3/src/lib/KEY2ParserUtils.h 2013-12-15 06:50:40.296884951 +0100
-@@ -81,6 +81,8 @@
- * @returns the boolean value of the string
- */
- static bool bool_cast(const char *value);
-+ static double double_cast(const char *value);
-+ static int int_cast(const char *value);
-
- static double deg2rad(double value);
-
---- libetonyek-0.0.3/src/lib/KEY2StyleParser.cpp 2013-12-06 10:36:13.000000000 +0100
-+++ libetonyek-0.0.3/src/lib/KEY2StyleParser.cpp 2013-12-15 06:53:45.353451061 +0100
-@@ -62,12 +62,12 @@
-
- optional<double> readDouble(const KEYXMLReader &reader)
- {
-- return readNumber<double>(reader, KEY2Token::f, &lexical_cast<double, const char *>);
-+ return readNumber<double>(reader, KEY2Token::f, &KEY2ParserUtils::double_cast);
- }
-
- optional<int> readInt(const KEYXMLReader &reader)
- {
-- return readNumber<int>(reader, KEY2Token::i, &lexical_cast<int, const char *>);
-+ return readNumber<int>(reader, KEY2Token::i, &KEY2ParserUtils::double_cast);
- }
-
- optional<KEYColor> readColor(const KEYXMLReader &reader)
diff --git a/app-text/libetonyek/libetonyek-0.0.3.ebuild b/app-text/libetonyek/libetonyek-0.0.3.ebuild
deleted file mode 100644
index b125b75da02b..000000000000
--- a/app-text/libetonyek/libetonyek-0.0.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libetonyek"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
-
-DESCRIPTION="Library parsing Apple Keynote presentations"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libetonyek"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="amd64 ~arm ~ppc x86"
-IUSE="doc static-libs test"
-
-RDEPEND="
- app-text/libwpd:0.9
- dev-libs/boost:=
- dev-libs/libxml2
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.46
- dev-util/gperf
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-comma.patch"
- "${FILESDIR}/${P}-lexical_cast.patch"
-)
-
-src_prepare() {
- [[ -d m4 ]] || mkdir "m4"
- base_src_prepare
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static) \
- --disable-werror \
- $(use_enable test tests) \
- $(use_with doc docs)
-}
-
-src_install() {
- default
- prune_libtool_files --all
-}