summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-15 20:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-15 20:40:08 +0100
commit1cad8d9858b286cafdb073837c0c91b8bfe6abf2 (patch)
tree0904fbac74e2c7371c7d737e252494d419792499 /app-text/libmwaw
parentapp-i18n/kinput2: Delete old version (3.1-r1). (diff)
downloadgentoo-1cad8d9858b286cafdb073837c0c91b8bfe6abf2.tar.gz
gentoo-1cad8d9858b286cafdb073837c0c91b8bfe6abf2.tar.bz2
gentoo-1cad8d9858b286cafdb073837c0c91b8bfe6abf2.zip
app-text/libmwaw: 0.3.13 version bump
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest1
-rw-r--r--app-text/libmwaw/libmwaw-0.3.13.ebuild49
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild3
3 files changed, 51 insertions, 2 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index bf42ca74af1b..c27e8fabba04 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,2 +1,3 @@
DIST libmwaw-0.3.11.tar.xz 1254200 SHA256 4b483a196bbe82bc0f7cb4cdf70ef1cedb91139bd2e037eabaed4a4d6ed2299a SHA512 d4a810c6066023608a15ece8a6bbc958e586d679fc4ad51156091ec88355292872f10198e723e28776b45e140a830fd4c698732cf6103743d6e80ad8e1d778ab WHIRLPOOL 2de11bde90937727372eb7e7d4d1af52b66e8ef2f14bd78ce1d26399aa6ee853dc1fe11000cfcf8a361698296866ced2f2da7848f75763a22458ae0504903b48
DIST libmwaw-0.3.12.tar.xz 1258972 SHA256 7691a6e6e7221d61c40e3f630a8907e3e516b99a587e47d09ec53f8ac60ed1e7 SHA512 8af8477ff6fc251600f9a66059b20fd8b9fad8d599c01e847d7185944447b3a34567036daff4d4510934aa1462bd4810a39467e8ac0ec223147b3b53447220ec WHIRLPOOL 9dd39fc43c7b8cf3806889a1cabde4c1bbd4f21e5e1ea2dfa66a6ea69f28ab28c966e160d157f0ee4559e85b6b7fac07dfa314d2ef0597986c85660b3a5cc0f9
+DIST libmwaw-0.3.13.tar.xz 1258220 SHA256 db55c728448f9c795cd71a0bb6043f6d4744e3e001b955a018a2c634981d5aea SHA512 3d6a5142cc45f6519ac29f935c01418278ed4cc1bdcb0ecb1a190309c43d3f7ee06deab519d29a3e2aec01ef091cb4f4c17809662640b54a8e4fe8d4bd8db5f3 WHIRLPOOL 34310e946e398f577c76f2eacda496b64417fe3f7bc5f02af7852f51fa94c46df6f4df397a02fe56c7585b19dc62b796723b878f7ed66adf3698c14261e01f73
diff --git a/app-text/libmwaw/libmwaw-0.3.13.ebuild b/app-text/libmwaw/libmwaw-0.3.13.ebuild
new file mode 100644
index 000000000000..0b26fe70b823
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="doc static-libs tools"
+
+RDEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --enable-zip \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index b0434c260bc2..0b26fe70b823 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -14,7 +14,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc static-libs tools"
@@ -38,7 +38,6 @@ src_configure() {
econf \
--enable-zip \
--disable-werror \
- --with-sharedptr=c++11 \
$(use_with doc docs) \
$(use_enable static-libs static) \
$(use_enable tools)