summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-26 19:35:12 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-05 22:00:49 +0100
commit3d22e0437060b1e11787d639ddd0e9feaa283786 (patch)
treeafffb989e76cfc21eb9323afcdecf9c94b7c5705 /app-text/libstaroffice
parentapp-office/libreoffice: Add media-libs/harfbuzz[graphite] to DEPEND (diff)
downloadgentoo-3d22e0437060b1e11787d639ddd0e9feaa283786.tar.gz
gentoo-3d22e0437060b1e11787d639ddd0e9feaa283786.tar.bz2
gentoo-3d22e0437060b1e11787d639ddd0e9feaa283786.zip
app-text/libstaroffice: Add 0.0.2 release
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/libstaroffice')
-rw-r--r--app-text/libstaroffice/Manifest1
-rw-r--r--app-text/libstaroffice/libstaroffice-0.0.2.ebuild45
-rw-r--r--app-text/libstaroffice/libstaroffice-9999.ebuild7
3 files changed, 48 insertions, 5 deletions
diff --git a/app-text/libstaroffice/Manifest b/app-text/libstaroffice/Manifest
new file mode 100644
index 000000000000..9fb791f94119
--- /dev/null
+++ b/app-text/libstaroffice/Manifest
@@ -0,0 +1 @@
+DIST libstaroffice-0.0.2.tar.bz2 886950 SHA256 f06eb29d13357f1aa1944de0be1162de05d9f9333b5f54e9bf762415029a8899 SHA512 dc66324dd8b365db73ea6dea16188b808648970311d443f09302648ab6b3d27c95e91f09f2be6d0d8ef173d8c5129afe6d493b1e2664dbe229553060142858e8 WHIRLPOOL 8a4b1baafea2d9cb38520e234c0b3e03a16d7fc479ff8f8807e19c9f7fd8d34536fdffb7426f85406e559c22e3196dab90238aad0b36fc63e8c7ca82bab3d59d
diff --git a/app-text/libstaroffice/libstaroffice-0.0.2.ebuild b/app-text/libstaroffice/libstaroffice-0.0.2.ebuild
new file mode 100644
index 000000000000..e6ce45953053
--- /dev/null
+++ b/app-text/libstaroffice/libstaroffice-0.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+DESCRIPTION="Import filter for old StarOffice documents"
+HOMEPAGE="https://github.com/fosnola/libstaroffice"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc tools +zlib"
+
+RDEPEND="
+ dev-libs/librevenge
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ $(use_enable zlib zip)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libstaroffice/libstaroffice-9999.ebuild b/app-text/libstaroffice/libstaroffice-9999.ebuild
index e5d61b81986b..e6ce45953053 100644
--- a/app-text/libstaroffice/libstaroffice-9999.ebuild
+++ b/app-text/libstaroffice/libstaroffice-9999.ebuild
@@ -5,10 +5,7 @@
EAPI=6
EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
-
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit eutils ${GITECLASS}
-unset GITECLASS
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
DESCRIPTION="Import filter for old StarOffice documents"
HOMEPAGE="https://github.com/fosnola/libstaroffice"
@@ -44,5 +41,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
}