summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-11-23 15:06:07 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-11-23 17:49:52 +0300
commit0b1e6698b130aa33ad9dda5d8a503476eba962d1 (patch)
tree0f96e05a027df25a2843475d59d4e961d0fd8a0d /app-text/linuxdoc-tools
parentsys-kernel/git-sources: Linux patch 4.4_rc2 (diff)
downloadgentoo-0b1e6698b130aa33ad9dda5d8a503476eba962d1.tar.gz
gentoo-0b1e6698b130aa33ad9dda5d8a503476eba962d1.tar.bz2
gentoo-0b1e6698b130aa33ad9dda5d8a503476eba962d1.zip
app-text/linuxdoc-tools: fix TeX styles installation, minor cleanups
Inherit latex-package eclass and rehash kpathsea database after installation and removal. Make TeX styles installation path consistent with latex-package eclass.
Diffstat (limited to 'app-text/linuxdoc-tools')
-rw-r--r--app-text/linuxdoc-tools/linuxdoc-tools-0.9.71-r1.ebuild (renamed from app-text/linuxdoc-tools/linuxdoc-tools-0.9.71.ebuild)19
1 files changed, 16 insertions, 3 deletions
diff --git a/app-text/linuxdoc-tools/linuxdoc-tools-0.9.71.ebuild b/app-text/linuxdoc-tools/linuxdoc-tools-0.9.71-r1.ebuild
index b2494b28be5e..b45639cc35fd 100644
--- a/app-text/linuxdoc-tools/linuxdoc-tools-0.9.71.ebuild
+++ b/app-text/linuxdoc-tools/linuxdoc-tools-0.9.71-r1.ebuild
@@ -3,11 +3,13 @@
# $Id$
EAPI=5
+
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
-
+# Source tarball has SHA1 of release in the name of the second topmost directory
GIT_SHA1="5a46c4ced4ef899b398bcedf8ccd29d6f2584100"
-inherit autotools-utils perl-module sgml-catalog toolchain-funcs
+
+inherit autotools-utils latex-package perl-module sgml-catalog toolchain-funcs
DESCRIPTION="A toolset for processing LinuxDoc DTD SGML files"
HOMEPAGE="https://gitlab.com/agmartin/linuxdoc-tools"
@@ -34,6 +36,7 @@ DEPEND="${RDEPEND}
"
DOCS=( ChangeLog README )
+
S="${WORKDIR}/${PN}-upstream/${PV}-${GIT_SHA1}"
sgml-catalog_cat_include "/etc/sgml/linuxdoc.cat" \
@@ -53,7 +56,7 @@ src_configure() {
tc-export CC
local myeconfargs=(
--disable-docs
- --with-texdir="/usr/share/texmf/tex/latex/misc"
+ --with-texdir="${TEXMF}/tex/latex/${PN}"
--with-perllibdir="${VENDOR_ARCH}"
--with-installed-iso-entities
)
@@ -72,3 +75,13 @@ src_install() {
autotools-utils_src_install
}
+
+pkg_postinst() {
+ latex-package_pkg_postinst
+ sgml-catalog_pkg_postinst
+}
+
+pkg_postrm() {
+ latex-package_pkg_postrm
+ sgml-catalog_pkg_postrm
+}