summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 08:51:08 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:20:15 +0200
commit8e4ee691ea0070ec9368105d05c6311cb1b2bef8 (patch)
tree6283040ab3b17777d19ab3adda7399226df161b0 /app-text/pdf2djvu
parentapp-misc/mswinurl_launcher: [QA] Add missing python metadata variables (diff)
downloadgentoo-8e4ee691ea0070ec9368105d05c6311cb1b2bef8.tar.gz
gentoo-8e4ee691ea0070ec9368105d05c6311cb1b2bef8.tar.bz2
gentoo-8e4ee691ea0070ec9368105d05c6311cb1b2bef8.zip
app-text/pdf2djvu: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text/pdf2djvu')
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.9.3.ebuild11
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.9.4.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/app-text/pdf2djvu/pdf2djvu-0.9.3.ebuild b/app-text/pdf2djvu/pdf2djvu-0.9.3.ebuild
index 2eb5f4de8a1b..af5fbd00e708 100644
--- a/app-text/pdf2djvu/pdf2djvu-0.9.3.ebuild
+++ b/app-text/pdf2djvu/pdf2djvu-0.9.3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1 toolchain-funcs
+inherit python-any-r1 toolchain-funcs
DESCRIPTION="A tool to create DjVu files from PDF files"
HOMEPAGE="http://jwilk.net/software/pdf2djvu"
@@ -27,13 +27,16 @@ DEPEND="${RDEPEND}
dev-cpp/pstreams
virtual/pkgconfig
nls? ( sys-devel/gettext )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/nose[${PYTHON_USEDEP}]')
+ )
"
REQUIRED_USE="test? ( graphicsmagick ${PYTHON_REQUIRED_USE} )"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {
diff --git a/app-text/pdf2djvu/pdf2djvu-0.9.4.ebuild b/app-text/pdf2djvu/pdf2djvu-0.9.4.ebuild
index 2e3ac901d1f3..af5fbd00e708 100644
--- a/app-text/pdf2djvu/pdf2djvu-0.9.4.ebuild
+++ b/app-text/pdf2djvu/pdf2djvu-0.9.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1 toolchain-funcs
+inherit python-any-r1 toolchain-funcs
DESCRIPTION="A tool to create DjVu files from PDF files"
HOMEPAGE="http://jwilk.net/software/pdf2djvu"
@@ -27,13 +27,16 @@ DEPEND="${RDEPEND}
dev-cpp/pstreams
virtual/pkgconfig
nls? ( sys-devel/gettext )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/nose[${PYTHON_USEDEP}]')
+ )
"
REQUIRED_USE="test? ( graphicsmagick ${PYTHON_REQUIRED_USE} )"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {