summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 16:37:14 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 17:14:39 +0200
commit9ff55e8920ae581f49227985a1b8a143f66959b9 (patch)
treebee9e587f5b1f4e0aad812673227ee033bb79c8c /app-text/pytextile/pytextile-2.3.2-r1.ebuild
parentdev-python/routes: Clean old versions up (diff)
downloadgentoo-9ff55e8920ae581f49227985a1b8a143f66959b9.tar.gz
gentoo-9ff55e8920ae581f49227985a1b8a143f66959b9.tar.bz2
gentoo-9ff55e8920ae581f49227985a1b8a143f66959b9.zip
app-text/pytextile: Clean old versions up
Diffstat (limited to 'app-text/pytextile/pytextile-2.3.2-r1.ebuild')
-rw-r--r--app-text/pytextile/pytextile-2.3.2-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/app-text/pytextile/pytextile-2.3.2-r1.ebuild b/app-text/pytextile/pytextile-2.3.2-r1.ebuild
deleted file mode 100644
index c3556f1e7241..000000000000
--- a/app-text/pytextile/pytextile-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-MY_PN="python-textile"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python port of Textile, A humane web text generator"
-HOMEPAGE="https://github.com/textile/python-textile"
-SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )
- "
-RDEPEND="
- dev-python/regex[${PYTHON_USEDEP}]
- "
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # This resolves a nasty race condition, courtesy of Arfrever
- sed -e 's:with-id = 1::' -i setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test || die "Testsuite failed under ${EPYTHON}"
-}