summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-17 16:27:45 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-17 16:37:42 +0200
commit5606999cb8ff87e1249c834ed0105e761663cfb8 (patch)
tree2162c81516c8a210e4f8c8d8177a2bb72b06ac38 /app-text/pytextile
parentdev-util/cmake-3.5.2-r1: add alpha keyword (diff)
downloadgentoo-5606999cb8ff87e1249c834ed0105e761663cfb8.tar.gz
gentoo-5606999cb8ff87e1249c834ed0105e761663cfb8.tar.bz2
gentoo-5606999cb8ff87e1249c834ed0105e761663cfb8.zip
app-text/pytextile: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/pytextile')
-rw-r--r--app-text/pytextile/Manifest1
-rw-r--r--app-text/pytextile/pytextile-2.3.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/pytextile/Manifest b/app-text/pytextile/Manifest
index 192b6019d5dd..13ca1b8d465c 100644
--- a/app-text/pytextile/Manifest
+++ b/app-text/pytextile/Manifest
@@ -1,3 +1,4 @@
DIST textile-2.1.8.tar.gz 34002 SHA256 c443f4bf0a31df9e707e615f869d4f51b08cdb222d17ca3009eda44f7cfd8629 SHA512 b1675a131b482f4926efb45312b16c722ff158d9296704918b56316d470056f986ce18d495525a8e9f236bdd62e09ca6a17b443a7db8c8c36e5d05fcffce67da WHIRLPOOL fedcd9b9277387604e258fca427e3cd587f3b2ba93e65b39474ce57810fa67dae772241c5cf69dc8aaf89416d6191271f1fece4fa2f2e63f19fec6597b956bd5
DIST textile-2.2.1.tar.gz 32631 SHA256 4899f06c63bfdc32a204d4c1c1e9302ddf17f26c20328419747d109348e23afd SHA512 81d044deaa765693078d949672affa787a4e15882cc2928fd19c3abe69256ffbeec1308b303ee694a80787ad7574b57ab4b256f111d9874e72440809236f6b93 WHIRLPOOL 3fda8226310d998b7d40d9fec6398173c8398c44704dd151400d284ba5a897a56bee6d3f17a21ed8fc01e76cea88f41a8372b90a4ad8a7eb6627de550dd0ef89
DIST textile-2.2.2.tar.gz 32844 SHA256 dba4f1cb5772b99dbe4d521807a3255ddbbfa971da8b054afa08f0b428bced28 SHA512 19f2ed92199549549b07c2bb3accdf483c409c2dfd17e43ae38ba8babbc2c72d662d78414de0fd1c64b65eae59ce9e591ab9c863d4f806b7c454d8a37567d882 WHIRLPOOL a2cf3f1ef03ccac807582fd9ca44acc7f6bf48d56445a9a73d756400c7b2f7952f3222ce87caa6dfded27c4a4f55feee57f2e3194082b2d44841b4953821ca0f
+DIST textile-2.3.2.tar.gz 24689 SHA256 918e7e7a1d8cdffd826c3028901f19eac8224829d8ced6d082b8a659add47989 SHA512 1e59f56fb0767d570079aad602ed699861ca9bdbdba039fedcb2fdf1e55791dc9ebe5458e0bcb0f65c4f8c0a220af5dd8fc59dce39a6c9661c7474d45ba7bca7 WHIRLPOOL c3105bc804151053742d682af6fe4ba0f07f4b6a5dd2b67022de7327bebaeee41e1e5a6d0af0325d4bb7551048c31ab248c491ac4e15d67713d2aca0fdce0cd5
diff --git a/app-text/pytextile/pytextile-2.3.2.ebuild b/app-text/pytextile/pytextile-2.3.2.ebuild
new file mode 100644
index 000000000000..ba03414ccdc4
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python implementation of Textile, Dean Allen's Human Text Generator for creating (X)HTML"
+HOMEPAGE="https://github.com/textile/python-textile"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # This resolves a nasty race condition, courtesy of Arfrever
+ sed -e 's:with-id = 1::' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}