summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-15 19:59:52 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 20:01:23 -0400
commitfdf1d951faa476913ddb313c45b4ba43c80da08c (patch)
tree2dcbdd23e6ec252f57cd1ee1043a608cd7b391d3 /app-text/pytextile
parentapp-text/pytextile: remove old (diff)
downloadgentoo-fdf1d951faa476913ddb313c45b4ba43c80da08c.tar.gz
gentoo-fdf1d951faa476913ddb313c45b4ba43c80da08c.tar.bz2
gentoo-fdf1d951faa476913ddb313c45b4ba43c80da08c.zip
app-text/pytextile: drop spurious pytest-cov dep
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text/pytextile')
-rw-r--r--app-text/pytextile/pytextile-2.3.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-text/pytextile/pytextile-2.3.3.ebuild b/app-text/pytextile/pytextile-2.3.3.ebuild
index 3a17b6c192d4..0cf0146b654e 100644
--- a/app-text/pytextile/pytextile-2.3.3.ebuild
+++ b/app-text/pytextile/pytextile-2.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,10 +20,7 @@ IUSE="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )
- "
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
RDEPEND="
dev-python/regex[${PYTHON_USEDEP}]
"
@@ -33,6 +30,8 @@ S="${WORKDIR}/${MY_P}"
python_prepare_all() {
# This resolves a nasty race condition, courtesy of Arfrever
sed -e 's:with-id = 1::' -i setup.cfg || die
+ # remove useless --cov arg injection
+ rm pytest.ini || die
distutils-r1_python_prepare_all
}