summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/reed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/reed')
-rw-r--r--app-text/reed/Manifest1
-rw-r--r--app-text/reed/metadata.xml7
-rw-r--r--app-text/reed/reed-5.4.ebuild34
3 files changed, 42 insertions, 0 deletions
diff --git a/app-text/reed/Manifest b/app-text/reed/Manifest
new file mode 100644
index 000000000000..fc40014b6d16
--- /dev/null
+++ b/app-text/reed/Manifest
@@ -0,0 +1 @@
+DIST reed-5.4.tar.gz 32414 SHA256 226a057aa5db705e83b685207d635d0d3b983999f1e526e0768aa56b0e7c02a8 SHA512 47216c6444ff2a53a0f6ad0e598761d078fb19099507e5687d15be7f875664d3cb9b74f2a4af8c450d179032e46785d96abc66c2bf9cd264db2f87aa089512f7 WHIRLPOOL f603ab7516bb09970ba1bdad52dc5aac7c76ceb61f7b74e3d7adf3eeb8382c7d3ce982b0a48c0b11fad041398a3c5cf7287a1b33e11bdc94aa9032ac045494cf
diff --git a/app-text/reed/metadata.xml b/app-text/reed/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-text/reed/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/reed/reed-5.4.ebuild b/app-text/reed/reed-5.4.ebuild
new file mode 100644
index 000000000000..1ce31f3505c9
--- /dev/null
+++ b/app-text/reed/reed-5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="This is a text pager (text file viewer), used to display etexts"
+# Homepage http://www.sacredchao.net/software/reed/index.shtml does not exist.
+HOMEPAGE="http://web.archive.org/web/20040217010815/www.sacredchao.net/software/reed/"
+SRC_URI="http://www.sacredchao.net/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_prepare() {
+ sed -e 's:-O2:$(CFLAGS) $(LDFLAGS):' \
+ -e 's: wrap::' \
+ -e 's:-s reed:reed:' \
+ -e 's:-lcurses:$(shell ${PKG_CONFIG} --libs ncurses):g' \
+ -i Makefile.in || die
+ rm wrap.1 #Collision with talkfilters, bug #247396
+ tc-export CC PKG_CONFIG
+}
+
+src_configure() {
+ ./configures --prefix=/usr || die
+}