summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/txt2tags
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/txt2tags')
-rw-r--r--app-text/txt2tags/Manifest1
-rw-r--r--app-text/txt2tags/files/51txt2tags-gentoo.el6
-rw-r--r--app-text/txt2tags/metadata.xml11
-rw-r--r--app-text/txt2tags/txt2tags-2.6-r1.ebuild81
-rw-r--r--app-text/txt2tags/txt2tags-2.6.ebuild91
5 files changed, 190 insertions, 0 deletions
diff --git a/app-text/txt2tags/Manifest b/app-text/txt2tags/Manifest
new file mode 100644
index 000000000000..51cb6820af2f
--- /dev/null
+++ b/app-text/txt2tags/Manifest
@@ -0,0 +1 @@
+DIST txt2tags-2.6.tgz 544724 SHA256 601467d7860f3cfb3d48050707c6277ff3ceb22fa7be4f5bd968de540ac5b05c SHA512 716e975f45dd304b6fd7d4e5aa8bd12e57c54120d892ae9abe11f1f3b5aeb747d8df0a9ffd34b8b5e6c8d422aac8830477f9a332c9e94040e1aa9946ebfe051e WHIRLPOOL d9cb30d9cfba1218b06698596e7213cac62b9adfa21c386ce65fe2919762425dac12cff493d5b5f70dac5bff9dffc3672f2b44e6165ffca5b7a96623b37e5ea3
diff --git a/app-text/txt2tags/files/51txt2tags-gentoo.el b/app-text/txt2tags/files/51txt2tags-gentoo.el
new file mode 100644
index 000000000000..0b98bd66b8b2
--- /dev/null
+++ b/app-text/txt2tags/files/51txt2tags-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; txt2tags site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 't2t-mode "txt2tags-mode" "Major mode for editing Txt2Tags files" t)
+(add-to-list 'auto-mode-alist '("\\.t2t\\'" . t2t-mode))
diff --git a/app-text/txt2tags/metadata.xml b/app-text/txt2tags/metadata.xml
new file mode 100644
index 000000000000..b95cef418f1a
--- /dev/null
+++ b/app-text/txt2tags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">txt2tags</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/txt2tags/txt2tags-2.6-r1.ebuild b/app-text/txt2tags/txt2tags-2.6-r1.ebuild
new file mode 100644
index 000000000000..d292e5cc5726
--- /dev/null
+++ b/app-text/txt2tags/txt2tags-2.6-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit eutils elisp-common python-single-r1
+
+DESCRIPTION="A tool for generating marked up documents (HTML, SGML, ...) from a plain text file with markup"
+HOMEPAGE="http://txt2tags.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="emacs tk vim-syntax"
+
+DEPEND="${PYTHON_DEPS}
+ tk? ( dev-lang/tk )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ if use emacs; then
+ elisp-compile extras/txt2tags-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ dobin txt2tags
+
+ dodoc README ChangeLog*
+ dodoc doc/*.{pdf,t2t}
+ dodoc -r samples extras
+ newman doc/manpage.man txt2tags.1
+
+ # make .po files
+ for pofile in "${S}"/po/*.po; do
+ msgfmt -o ${pofile%%.po}.mo ${pofile}
+ done
+ domo po/*.mo
+
+ # emacs support
+ if use emacs; then
+ elisp-install ${PN} extras/txt2tags-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins extras/txt2tags.vim || die
+
+ echo 'au BufNewFile,BufRead *.t2t set ft=txt2tags' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim" || die
+ fi
+
+ python_fix_shebang "${D}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-text/txt2tags/txt2tags-2.6.ebuild b/app-text/txt2tags/txt2tags-2.6.ebuild
new file mode 100644
index 000000000000..5163c9e748b3
--- /dev/null
+++ b/app-text/txt2tags/txt2tags-2.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_USE_WITH="tk"
+PYTHON_USE_WITH_OPT="tk"
+PYTHON_DEPEND="2"
+
+inherit eutils elisp-common python
+
+DESCRIPTION="A tool for generating marked up documents (HTML, SGML, ...) from a plain text file with markup"
+HOMEPAGE="http://txt2tags.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="emacs tk vim-syntax"
+
+DEPEND="dev-lang/python
+ tk? ( dev-lang/tk )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ if use emacs; then
+ elisp-compile extras/txt2tags-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ dobin txt2tags || die
+
+ dodoc README ChangeLog* || die
+ insinto /usr/share/doc/${PF}
+ doins doc/*.{pdf,t2t} || die
+ # samples go into "samples" doc directory
+ docinto samples
+ dodoc samples/sample.* || die
+ docinto samples/css
+ dodoc samples/css/* || die
+ docinto samples/img
+ dodoc samples/img/* || die
+ docinto samples/module
+ dodoc samples/module/* || die
+ # extras go into "extras" doc directory
+ insinto /usr/share/doc/${PF}/extras
+ doins -r extras/* || die
+ newman doc/manpage.man txt2tags.1 || die
+
+ # make .po files
+ for pofile in "${S}"/po/*.po; do
+ msgfmt -o ${pofile%%.po}.mo ${pofile}
+ done
+ domo po/*.mo
+
+ # emacs support
+ if use emacs; then
+ elisp-install ${PN} extras/txt2tags-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins extras/txt2tags.vim || die
+
+ echo 'au BufNewFile,BufRead *.t2t set ft=txt2tags' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim" || die
+ fi
+
+ python_convert_shebangs -r 2 "${D}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}