summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-07-30 16:20:23 -0700
committerDaniel Campbell <zlg@gentoo.org>2017-07-30 16:20:40 -0700
commitb42547814bb2aef7ec11a45e14502ff67ca26e0d (patch)
treeba0a331189bc71ac3a398e627717c5476a50f984 /app-text/wdiff
parentmedia-libs/phonon: Dekeyword hppa (diff)
downloadgentoo-b42547814bb2aef7ec11a45e14502ff67ca26e0d.tar.gz
gentoo-b42547814bb2aef7ec11a45e14502ff67ca26e0d.tar.bz2
gentoo-b42547814bb2aef7ec11a45e14502ff67ca26e0d.zip
app-text/wdiff: add sys-apps/texinfo to DEPEND
* Add sys-apps/texinfo to DEPEND * Update Copyright year * Bump to EAPI=6 * Correct ncurses's missing SLOT operators Bug: 614964 Gentoo-Bug-URL: https://bugs.gentoo.org/614964 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-text/wdiff')
-rw-r--r--app-text/wdiff/wdiff-1.2.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/wdiff/wdiff-1.2.2-r1.ebuild b/app-text/wdiff/wdiff-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..88b88f79755c
--- /dev/null
+++ b/app-text/wdiff/wdiff-1.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="https://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="experimental test"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/less
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ test? ( app-misc/screen )"
+
+src_configure() {
+ econf \
+ $(use_enable experimental)
+}
+
+src_test() {
+ # The test suite hangs in the '3: use pager' test
+ # when an incompatible screenrc is found
+ touch tests/screenrc || die
+ export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+ default
+}