summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-04-08 18:46:54 -0400
committerTim Harder <radhermit@gentoo.org>2018-04-08 19:00:35 -0400
commitece8c0fc391ac73dc8deaccaff4a48b9a851258d (patch)
treeb6eca977a033291d09c222daa36214ab19d12f39 /app-text/yodl
parentdev-util/icmake: version bump to 9.02.07 (diff)
downloadgentoo-ece8c0fc391ac73dc8deaccaff4a48b9a851258d.tar.gz
gentoo-ece8c0fc391ac73dc8deaccaff4a48b9a851258d.tar.bz2
gentoo-ece8c0fc391ac73dc8deaccaff4a48b9a851258d.zip
app-text/yodl: version bump to 4.02.00
Diffstat (limited to 'app-text/yodl')
-rw-r--r--app-text/yodl/Manifest1
-rw-r--r--app-text/yodl/yodl-4.02.00.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/yodl/Manifest b/app-text/yodl/Manifest
index c2c1f91960e7..15d5396a0426 100644
--- a/app-text/yodl/Manifest
+++ b/app-text/yodl/Manifest
@@ -1 +1,2 @@
DIST yodl-4.01.00.tar.gz 288932 BLAKE2B 71491eaedae9cf0b6bc65f1da3065bc2a90e9ff5f527cbac66a714c761e679600635f7f10b0f20b7e1a15413c1930ee6e64e5ec083226058b6c8822e4a445437 SHA512 f195dec8e03b83561b47f9bd00fbb0fe711bbc254c32413d748587d8bf3848e050b90a2140977bec5a335021b2ef49ec5a6b0ca89f1649def495d81c3e7b437f
+DIST yodl-4.02.00.tar.gz 308567 BLAKE2B bf64ff7248ddcdc17dec23fe4407c28edf604b76746f13e97dfbb470421c15ca6235747c9ef349925a0293f8503d319a637a11352a2987f161fb2bcab60ddf7e SHA512 ca3a2490bf54a0ce4e800a62a3de9a5cf37df96f0f553de89623ef6d36f07b65b7c09168e77d267d7fb79d900a8e8a6c6d3c17c4b733345001213f5450c02b13
diff --git a/app-text/yodl/yodl-4.02.00.ebuild b/app-text/yodl/yodl-4.02.00.ebuild
new file mode 100644
index 000000000000..99795591e6d6
--- /dev/null
+++ b/app-text/yodl/yodl-4.02.00.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
+HOMEPAGE="https://fbb-git.github.io/yodl/ https://github.com/fbb-git/yodl"
+SRC_URI="https://github.com/fbb-git/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-util/icmake-8.00.00"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
+ -e "/COMPILER =/s/gcc/$(tc-getCC)/" \
+ -e "/CXX =/s/g++/$(tc-getCXX)/" \
+ -i INSTALL.im || die
+
+ sed -e "s/ar r /$(tc-getAR) r /" \
+ -e "s/ranlib/$(tc-getRANLIB)/" \
+ -i icmake/stdcompile || die
+
+ default
+}
+
+src_compile() {
+ ./build programs || die
+ ./build macros || die
+ ./build man || die
+ use doc && { ./build manual || die ; }
+}
+
+src_install() {
+ ./build install programs "${ED}" || die
+ ./build install macros "${ED}" || die
+ ./build install man "${ED}" || die
+ ./build install docs "${ED}" || die
+ use doc && { ./build install manual "${ED}" || die ; }
+}