summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-03 21:05:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-03 21:08:00 +0100
commit1bdf7c82e558cdc3fa4c0e600aee355d35bf0f1c (patch)
tree2d210a8daa486a00bf919348201ba0b4a0eb14b8 /app-text
parentapp-text/scrollkeeper: Allow revbumps of scrollkeeper-dtd (diff)
downloadgentoo-1bdf7c82e558cdc3fa4c0e600aee355d35bf0f1c.tar.gz
gentoo-1bdf7c82e558cdc3fa4c0e600aee355d35bf0f1c.tar.bz2
gentoo-1bdf7c82e558cdc3fa4c0e600aee355d35bf0f1c.zip
app-text/highlight: Fix help menu items
Thanks-to: Chris Mayo <aklhfex@gmail.com> Closes: https://bugs.gentoo.org/649398 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/highlight/files/highlight-3.42-qmake-fix.patch32
-rw-r--r--app-text/highlight/highlight-3.42-r1.ebuild (renamed from app-text/highlight/highlight-3.42.ebuild)7
2 files changed, 38 insertions, 1 deletions
diff --git a/app-text/highlight/files/highlight-3.42-qmake-fix.patch b/app-text/highlight/files/highlight-3.42-qmake-fix.patch
new file mode 100644
index 000000000000..31970057d9a6
--- /dev/null
+++ b/app-text/highlight/files/highlight-3.42-qmake-fix.patch
@@ -0,0 +1,32 @@
+From 8464afed560fa1096d37aa82aef99c00819fec87 Mon Sep 17 00:00:00 2001
+From: Chris Mayo <aklhfex@gmail.com>
+Date: Fri, 2 Mar 2018 19:15:35 +0000
+Subject: [PATCH] fix directories passed to qmake being ignored
+
+contains() matches the whole value, add regular expressions for the path
+components.
+---
+ src/gui-qt/highlight.pro | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/gui-qt/highlight.pro b/src/gui-qt/highlight.pro
+index bae8d7c..0380a90 100644
+--- a/src/gui-qt/highlight.pro
++++ b/src/gui-qt/highlight.pro
+@@ -43,13 +43,13 @@ unix {
+ PKGCONFIG += lua
+
+ # to make it run within Qt Creator
+- !contains(DEFINES, DATA_DIR) {
++ !contains(DEFINES, DATA_DIR.*) {
+ DEFINES+=DATA_DIR=\\\"/usr/share/highlight/\\\"
+ }
+- !contains(DEFINES, CONFIG_DIR) {
++ !contains(DEFINES, CONFIG_DIR.*) {
+ DEFINES+=CONFIG_DIR=\\\"/etc/highlight/\\\"
+ }
+- !contains(DEFINES, DOC_DIR) {
++ !contains(DEFINES, DOC_DIR.*) {
+ DEFINES+=DOC_DIR=\\\"/usr/share/doc/highlight/\\\"
+ }
+ }
diff --git a/app-text/highlight/highlight-3.42.ebuild b/app-text/highlight/highlight-3.42-r1.ebuild
index 72295826fe12..26f4cd2c4455 100644
--- a/app-text/highlight/highlight-3.42.ebuild
+++ b/app-text/highlight/highlight-3.42-r1.ebuild
@@ -42,6 +42,8 @@ myhlopts=(
"conf_dir=${EPREFIX}/etc/highlight/"
)
+PATCHES=( "${FILESDIR}"/${P}-qmake-fix.patch ) # bug 649398
+
src_prepare() {
default
@@ -78,7 +80,10 @@ src_compile() {
src_install() {
emake -f makefile "${myhlopts[@]}" install
- use qt5 && emake -f makefile "${myhlopts[@]}" install-gui
+ if use qt5; then
+ emake -f makefile "${myhlopts[@]}" install-gui
+ docompress -x /usr/share/doc/${PF}/{ChangeLog,COPYING,README,README_PLUGINS}
+ fi
if ! use examples ; then
rm -r "${ED}"/usr/share/doc/${PF}/extras || die