summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-17 14:00:38 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-17 14:02:15 +0100
commit533ccd1da3f2c570a4b98f37d4b57741f284cbdf (patch)
treeb0aae6926220e65a89bd7a03d788ffe2079bb7ee /app-text
parentdev-libs/libclc: Fix building against slotted LLVM (diff)
downloadgentoo-533ccd1da3f2c570a4b98f37d4b57741f284cbdf.tar.gz
gentoo-533ccd1da3f2c570a4b98f37d4b57741f284cbdf.tar.bz2
gentoo-533ccd1da3f2c570a4b98f37d4b57741f284cbdf.zip
app-text/poppler: Bump to version 0.52.0
Removed cairo-qt support as the patches don't apply anymore. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-0.52.0.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 60043cbec777..a1713618d594 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,3 +2,4 @@ DIST poppler-0.45.0.tar.xz 1674464 SHA256 96dd1a6024bcdaa4530a3b49687db3d5c24ddf
DIST poppler-0.49.0.tar.xz 1685860 SHA256 14485f0e1e43dcddf49cfc02c2ccb92910ba3e0e91e06f4bd2642ec00cb3a79f SHA512 f840c28688318693efdf5af70608c72cdfc80399c33dc6f929918775b43b0c36695d8accc50fdce5d7c6bd0503206488d9658291613393e6ead0174bcb29dd79 WHIRLPOOL a3f9b13add6e103b491456abc7571dcdf66a3a1285c4dfe21289468d13b384adc1d99fb9ed8de4cc9150683914cc513666df6d0e218531e01acbd0884979cc9d
DIST poppler-0.50.0.tar.xz 1689260 SHA256 c9c93318b789d3933f6e0bad3bc65110280c28eac3f0666284bb9c9a0ab4bc36 SHA512 81e7b69126dbb06195c68e94d4ffc09bd5beab61c3330ab9e3ca42ce3c9717f18909aa0fe05542c291410f3195d1246b339eaa918fc0aff63d42cbced23b8e8e WHIRLPOOL a2df6f527eaba8324ac700c7fcdf65c9830d54548b721ed1136a713f5a9b3c7dc4a32c0dda4f6ef32a0febbe090ceb31a7361d0707a5b5d1043cd6ccba24f7f9
DIST poppler-0.51.0.tar.xz 1691504 SHA256 e997c9ad81a8372f2dd03a02b00692b8cc479c220340c8881edaca540f402c1f SHA512 f2e49cc8587396e38ac9125fa662bcb472eb0b9c9e0ce57135d72ad1792d55db858c7d00b8322b52ac3fe0cd97eacd2d570d3e579367c4acf2f04051f723c5c5 WHIRLPOOL 5e625db67411d1a3b9da4fbd78c82cfef03b78dd03854f3d1ab394b2bc0f6afe3f27983ee03d67ab03d28b29f94375332ef03d6c2263750125579f99428fd819
+DIST poppler-0.52.0.tar.xz 1692144 SHA256 528b661738839f9a25f6e580fcd2d5db007e0a1948580c6489f0062798ca1992 SHA512 8047af6cb6b1daff12f26463addbaaf532ef1f5c5185bc37eba6bc110438bc88687115bfec2802d738612fbc0c51ca5f7a5182989a23e30a05e9dab7ae4f5a52 WHIRLPOOL 024ae2ce4a68bbf77a6147fd73488cef3363f8a2d87eb11feb6148d2d22b2e04bac315e6b4ecfa8583c4e027f1f599343b1f93dce3efef80d4d8fecb200ae35f
diff --git a/app-text/poppler/poppler-0.52.0.ebuild b/app-text/poppler/poppler-0.52.0.ebuild
new file mode 100644
index 000000000000..065109840cdd
--- /dev/null
+++ b/app-text/poppler/poppler-0.52.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs xdg-utils
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.freedesktop.org/git/${PN}/${PN}"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/66" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( >=app-text/poppler-data-0.4.7 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
+ "${FILESDIR}/${PN}-0.28.1-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.33.0-openjpeg2.patch"
+ "${FILESDIR}/${PN}-0.40-FindQt4.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -i -e 's/-fno-check-new//' cmake/modules/PopplerMacros.cmake || die
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_XPDF_HEADERS=ON
+ -DENABLE_LIBCURL="$(usex curl)"
+ -DENABLE_CPP="$(usex cxx)"
+ -DENABLE_UTILS="$(usex utils)"
+ -DSPLASH_CMYK=OFF
+ -DUSE_FIXEDPOINT=OFF
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo="$(usex cairo)"
+ -DWITH_GObjectIntrospection="$(usex introspection)"
+ -DWITH_JPEG="$(usex jpeg)"
+ -DWITH_NSS3="$(usex nss)"
+ -DWITH_PNG="$(usex png)"
+ -DWITH_Qt4="$(usex qt4)"
+ $(cmake-utils_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF="$(usex tiff)"
+ )
+ if use jpeg2k; then
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
+ else
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=)
+ fi
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != 9999 ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}